summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-22 00:08:39 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-22 00:08:39 -0500
commitc297e9d21b3c1a935f4831f0608a3a4ee6e0e87e (patch)
tree642419fb81ee44abc22912b62f653f1373e48aeb /games-board/aisleriot/aisleriot-3.22.7.ebuild
parentgnome-meson.eclass: Remove (diff)
downloadgnome-master.tar.gz
gnome-master.tar.bz2
gnome-master.zip
Empty the overlayHEADmaster
None of this is useful. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-board/aisleriot/aisleriot-3.22.7.ebuild')
-rw-r--r--games-board/aisleriot/aisleriot-3.22.7.ebuild88
1 files changed, 0 insertions, 88 deletions
diff --git a/games-board/aisleriot/aisleriot-3.22.7.ebuild b/games-board/aisleriot/aisleriot-3.22.7.ebuild
deleted file mode 100644
index d103a6a9..00000000
--- a/games-board/aisleriot/aisleriot-3.22.7.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-GNOME2_EAUTORECONF="yes"
-
-inherit gnome2
-
-DESCRIPTION="A collection of solitaire card games for GNOME"
-HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Aisleriot"
-
-LICENSE="GPL-3 LGPL-3 FDL-1.3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug gnome qt5"
-
-# FIXME: quartz support?
-# Lookup guile modules grep "use-modules" *.scm
-COMMON_DEPEND="
- >=dev-libs/glib-2.32:2
- >=dev-scheme/guile-2.2:12
- >=gnome-base/librsvg-2.32:2
- >=media-libs/libcanberra-0.26[gtk3]
- >=x11-libs/cairo-1.10
- >=x11-libs/gtk+-3.4:3
- gnome? ( >=gnome-base/gconf-2.0:2 )
- qt5? ( >=dev-qt/qtsvg-5:5 )
-"
-DEPEND="${COMMON_DEPEND}
- app-arch/gzip
- app-text/yelp-tools
- dev-libs/libxml2:2
- dev-util/glib-utils
- >=dev-util/intltool-0.40.4
- gnome-base/gnome-common
- sys-apps/lsb-release
- sys-devel/autoconf-archive
- >=sys-devel/gettext-0.12
- virtual/pkgconfig
- gnome? ( app-text/docbook-xml-dtd:4.3 )
-"
-
-PATCHES=(
- # Fix SVG detection and usage
- "${FILESDIR}"/${PN}-3.22.0-detect-svg.patch
- # Fix build with Qt5, bug #617256
- "${FILESDIR}"/${PN}-3.22.2-qt5-requires-cxx11.patch
-)
-
-src_configure() {
- local myconf=()
-
- if use gnome; then
- myconf+=(
- --with-platform=gnome
- --with-help-method=ghelp
- )
- else
- myconf+=(
- --with-platform=gtk-only
- --with-help-method=library
- )
- fi
-
- if use qt5 ; then
- myconf+=(
- --with-card-theme-formats=all
- --with-kde-card-theme-path="${EPREFIX}"/usr/share/apps/carddecks
- )
- else
- myconf+=( --with-card-theme-formats=svg,fixed,pysol )
- fi
-
- gnome2_src_configure \
- --with-gtk=3.0 \
- --with-guile=2.2 \
- $(usex debug --enable-debug=yes --enable-debug=minimum) \
- --enable-sound \
- --with-pysol-card-theme-path="${EPREFIX}${GAMES_DATADIR}"/pysolfc \
- ${myconf[@]}
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- elog "Aisleriot can use additional card themes from games-board/pysolfc"
- elog "and kde-base/libkdegames."
-}