summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-15 23:11:35 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-21 00:54:55 +0200
commit0b5669846812cc52272b2ab08eb3ac9cf8466d20 (patch)
treeec73b92964b7a39f998a2cdcee13c41cffd44da4 /x11-libs/gtksourceview
parenteclass/gnome2.eclass: sync with gentoo-x86 (diff)
downloadgnome-0b5669846812cc52272b2ab08eb3ac9cf8466d20.tar.gz
gnome-0b5669846812cc52272b2ab08eb3ac9cf8466d20.tar.bz2
gnome-0b5669846812cc52272b2ab08eb3ac9cf8466d20.zip
x11-libs/gtksourceview: 3.10.2 → 3.12.0
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/Manifest11
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.12.0.ebuild51
-rw-r--r--x11-libs/gtksourceview/gtksourceview-9999.ebuild6
3 files changed, 65 insertions, 3 deletions
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
new file mode 100644
index 00000000..c1e9ec70
--- /dev/null
+++ b/x11-libs/gtksourceview/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gtksourceview-3.12.0.tar.xz 1194088 SHA256 633fe802d23b9642a2cdfc2131bd67ed3c4355735d4bcbad0fbbde82a21efbdb SHA512 3cca7042a3e08b8630fdb884eb46cdf2988ec6c170932e278817265224701d5dc649ef9e09750f9eb9735adb18d19de6546519efcd61f754575f768e282ba157 WHIRLPOOL 89c5b2b6ec4471533834bdde0e9729f7e01d4081c8c08c4ed35ba7303ba6417c3720ea62acffae836d95e342690f165796086f2ff3fff9ee7054aac68897bf99
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.22 (GNU/Linux)
+
+iEYEAREKAAYFAlNNoIgACgkQ1fmVwcYIWAZVlACfY1cZ3Ze8NNHkWyIMedrS77Jz
+FvEAoMPUbtIZIMgRYBonDHbnT2x+U65e
+=Hp8g
+-----END PGP SIGNATURE-----
diff --git a/x11-libs/gtksourceview/gtksourceview-3.12.0.ebuild b/x11-libs/gtksourceview/gtksourceview-3.12.0.ebuild
new file mode 100644
index 00000000..708853c9
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.12.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://projects.gnome.org/gtksourceview/"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3.0/2"
+IUSE="glade +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+# Note: has native OSX support, prefix teams, attack!
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/gtk+-3.11:3[introspection?]
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-deprecations \
+ --enable-providers \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS HACKING MAINTAINERS NEWS README"
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}
diff --git a/x11-libs/gtksourceview/gtksourceview-9999.ebuild b/x11-libs/gtksourceview/gtksourceview-9999.ebuild
index 8269551a..170edb9f 100644
--- a/x11-libs/gtksourceview/gtksourceview-9999.ebuild
+++ b/x11-libs/gtksourceview/gtksourceview-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -27,7 +27,7 @@ fi
RDEPEND="
>=dev-libs/glib-2.37.3:2
>=dev-libs/libxml2-2.6:2
- >=x11-libs/gtk+-3.9.9:3[introspection?]
+ >=x11-libs/gtk+-3.11:3[introspection?]
glade? ( >=dev-util/glade-3.9:3.10 )
introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
"
@@ -56,7 +56,7 @@ src_test() {
}
src_install() {
- DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+ DOCS="AUTHORS HACKING MAINTAINERS NEWS README"
gnome2_src_install
insinto /usr/share/${PN}-3.0/language-specs