aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-23 08:54:49 +0000
committerSam James <sam@gentoo.org>2024-02-23 08:54:49 +0000
commit2b9f0c114be8ddd8ff6c88805f2ecd8aa04e6ffe (patch)
tree5bd107f18363cbe8811b1ca1359120f74b39c355
parentkde-apps/killbots: sync <9999 (diff)
downloadkde-2b9f0c114be8ddd8ff6c88805f2ecd8aa04e6ffe.tar.gz
kde-2b9f0c114be8ddd8ff6c88805f2ecd8aa04e6ffe.tar.bz2
kde-2b9f0c114be8ddd8ff6c88805f2ecd8aa04e6ffe.zip
kde-apps/cantor: -j1 workaround
Bug: https://bugs.gentoo.org/919576 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--kde-apps/cantor/cantor-24.01.95.ebuild5
-rw-r--r--kde-apps/cantor/cantor-24.02.0.ebuild5
-rw-r--r--kde-apps/cantor/cantor-24.02.49.9999.ebuild5
-rw-r--r--kde-apps/cantor/cantor-9999.ebuild5
4 files changed, 20 insertions, 0 deletions
diff --git a/kde-apps/cantor/cantor-24.01.95.ebuild b/kde-apps/cantor/cantor-24.01.95.ebuild
index dbc325b71c..ec59607c7f 100644
--- a/kde-apps/cantor/cantor-24.01.95.ebuild
+++ b/kde-apps/cantor/cantor-24.01.95.ebuild
@@ -100,6 +100,11 @@ src_configure() {
ecm_src_configure
}
+src_compile() {
+ # -j1 for bug #919576
+ MAKEOPTS="-j1" ecm_src_compile
+}
+
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "Maxima backend" sci-mathematics/maxima
diff --git a/kde-apps/cantor/cantor-24.02.0.ebuild b/kde-apps/cantor/cantor-24.02.0.ebuild
index 25d1ffb4ac..b67c2d46df 100644
--- a/kde-apps/cantor/cantor-24.02.0.ebuild
+++ b/kde-apps/cantor/cantor-24.02.0.ebuild
@@ -100,6 +100,11 @@ src_configure() {
ecm_src_configure
}
+src_compile() {
+ # -j1 for bug #919576
+ MAKEOPTS="-j1" ecm_src_compile
+}
+
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "Maxima backend" sci-mathematics/maxima
diff --git a/kde-apps/cantor/cantor-24.02.49.9999.ebuild b/kde-apps/cantor/cantor-24.02.49.9999.ebuild
index 3e6f3ced91..a79facb107 100644
--- a/kde-apps/cantor/cantor-24.02.49.9999.ebuild
+++ b/kde-apps/cantor/cantor-24.02.49.9999.ebuild
@@ -100,6 +100,11 @@ src_configure() {
ecm_src_configure
}
+src_compile() {
+ # -j1 for bug #919576
+ MAKEOPTS="-j1" ecm_src_compile
+}
+
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "Maxima backend" sci-mathematics/maxima
diff --git a/kde-apps/cantor/cantor-9999.ebuild b/kde-apps/cantor/cantor-9999.ebuild
index 3e6f3ced91..a79facb107 100644
--- a/kde-apps/cantor/cantor-9999.ebuild
+++ b/kde-apps/cantor/cantor-9999.ebuild
@@ -100,6 +100,11 @@ src_configure() {
ecm_src_configure
}
+src_compile() {
+ # -j1 for bug #919576
+ MAKEOPTS="-j1" ecm_src_compile
+}
+
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "Maxima backend" sci-mathematics/maxima