aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-apps/cantor/cantor-24.01.95.ebuild5
-rw-r--r--kde-apps/cantor/cantor-24.02.0.ebuild5
-rw-r--r--kde-apps/cantor/cantor-24.02.49.9999.ebuild5
-rw-r--r--kde-apps/cantor/cantor-9999.ebuild5
4 files changed, 20 insertions, 0 deletions
diff --git a/kde-apps/cantor/cantor-24.01.95.ebuild b/kde-apps/cantor/cantor-24.01.95.ebuild
index dbc325b71c..ec59607c7f 100644
--- a/kde-apps/cantor/cantor-24.01.95.ebuild
+++ b/kde-apps/cantor/cantor-24.01.95.ebuild
@@ -100,6 +100,11 @@ src_configure() {
ecm_src_configure
}
+src_compile() {
+ # -j1 for bug #919576
+ MAKEOPTS="-j1" ecm_src_compile
+}
+
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "Maxima backend" sci-mathematics/maxima
diff --git a/kde-apps/cantor/cantor-24.02.0.ebuild b/kde-apps/cantor/cantor-24.02.0.ebuild
index 25d1ffb4ac..b67c2d46df 100644
--- a/kde-apps/cantor/cantor-24.02.0.ebuild
+++ b/kde-apps/cantor/cantor-24.02.0.ebuild
@@ -100,6 +100,11 @@ src_configure() {
ecm_src_configure
}
+src_compile() {
+ # -j1 for bug #919576
+ MAKEOPTS="-j1" ecm_src_compile
+}
+
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "Maxima backend" sci-mathematics/maxima
diff --git a/kde-apps/cantor/cantor-24.02.49.9999.ebuild b/kde-apps/cantor/cantor-24.02.49.9999.ebuild
index 3e6f3ced91..a79facb107 100644
--- a/kde-apps/cantor/cantor-24.02.49.9999.ebuild
+++ b/kde-apps/cantor/cantor-24.02.49.9999.ebuild
@@ -100,6 +100,11 @@ src_configure() {
ecm_src_configure
}
+src_compile() {
+ # -j1 for bug #919576
+ MAKEOPTS="-j1" ecm_src_compile
+}
+
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "Maxima backend" sci-mathematics/maxima
diff --git a/kde-apps/cantor/cantor-9999.ebuild b/kde-apps/cantor/cantor-9999.ebuild
index 3e6f3ced91..a79facb107 100644
--- a/kde-apps/cantor/cantor-9999.ebuild
+++ b/kde-apps/cantor/cantor-9999.ebuild
@@ -100,6 +100,11 @@ src_configure() {
ecm_src_configure
}
+src_compile() {
+ # -j1 for bug #919576
+ MAKEOPTS="-j1" ecm_src_compile
+}
+
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "Maxima backend" sci-mathematics/maxima