summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2019-06-27 07:11:10 -0400
committerMike Pagano <mpagano@gentoo.org>2019-06-27 07:11:10 -0400
commit1aa6e1b489ad4c1e2be82358841872b1de015040 (patch)
tree3af753f074c3cb164b51b0a3e15e9330cb828e12
parentLinux patch 4.4.183 (diff)
downloadlinux-patches-1aa6e1b4.tar.gz
linux-patches-1aa6e1b4.tar.bz2
linux-patches-1aa6e1b4.zip
Linux patch 4.4.1844.4-185
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1183_linux-4.4.184.patch25
2 files changed, 29 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index eb4744ab..dfc4ff61 100644
--- a/0000_README
+++ b/0000_README
@@ -775,6 +775,10 @@ Patch: 1182_linux-4.4.183.patch
From: http://www.kernel.org
Desc: Linux 4.4.183
+Patch: 1183_linux-4.4.184.patch
+From: http://www.kernel.org
+Desc: Linux 4.4.184
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1183_linux-4.4.184.patch b/1183_linux-4.4.184.patch
new file mode 100644
index 00000000..3f085a56
--- /dev/null
+++ b/1183_linux-4.4.184.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile b/Makefile
+index 4ac762e01e60..f098274d3ac3 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ VERSION = 4
+ PATCHLEVEL = 4
+-SUBLEVEL = 183
++SUBLEVEL = 184
+ EXTRAVERSION =
+ NAME = Blurry Fish Butt
+
+diff --git a/net/ipv4/tcp_output.c b/net/ipv4/tcp_output.c
+index bed83990847a..53edd60fd381 100644
+--- a/net/ipv4/tcp_output.c
++++ b/net/ipv4/tcp_output.c
+@@ -1161,7 +1161,7 @@ int tcp_fragment(struct sock *sk, struct sk_buff *skb, u32 len,
+ if (nsize < 0)
+ nsize = 0;
+
+- if (unlikely((sk->sk_wmem_queued >> 1) > sk->sk_sndbuf)) {
++ if (unlikely((sk->sk_wmem_queued >> 1) > sk->sk_sndbuf + 0x20000)) {
+ NET_INC_STATS(sock_net(sk), LINUX_MIB_TCPWQUEUETOOBIG);
+ return -ENOMEM;
+ }