aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-18 17:31:39 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-18 17:31:39 +0100
commit7773cb44751d5bcaf7af57bbb4910ec431cbb499 (patch)
tree12220dd5ede600a885ef98d149406dee10158d3b
parentUpdate local USE description (diff)
parentsci-biology/psychopy: updated source link (diff)
downloadsci-7773cb44.tar.gz
sci-7773cb44.tar.bz2
sci-7773cb44.zip
Merge pull request #569 from TheChymera/psychopy
sci-biology/psychopy version bump
-rw-r--r--sci-biology/psychopy/Manifest1
-rw-r--r--sci-biology/psychopy/psychopy-1.83.03.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sci-biology/psychopy/Manifest b/sci-biology/psychopy/Manifest
index 02ef47a6d..3e01d7e84 100644
--- a/sci-biology/psychopy/Manifest
+++ b/sci-biology/psychopy/Manifest
@@ -1 +1,2 @@
DIST PsychoPy-1.78.00.zip 6376071 SHA256 ac74ea948f400a4a962a6abde7e7360fce5738a0f44aec4a0ff636d00976cc25 SHA512 ec2cd1c2094488d2b02c94070c7bc3d50e12e597c0107d2f64d49522e43a12c81b060b7a8abc15e83d50736776ee9d3d7190b78d39c58ee8f8be88b32330c5e2 WHIRLPOOL 9395a55bb820d2d326f4d95e12fb7513fbc4038eea25d0fd182e7e909e86d153374ac14293e89162761f0655b14bb8ca2abfa7fdf3df3e1951bec11e469db1f7
+DIST psychopy-1.83.03.zip 11674131 SHA256 ac85489d95d7b2ec4b6151a074b0f3c5ca40983c98acc3583f6bb98409682d4f SHA512 3c1144bdac3a396583055fc3e336fd3a810a38955228b4b225463907427bab39fd354b8b0dc4559f616f01ad2e507a416268da0dc80400d4fa501b5c20c7e0a2 WHIRLPOOL 407b90bda35084714da02805eedc1cdb090e7ff8fa8f8f577f0473e07e39b02101ea9c013cfcf56ea52315a26cdd4d1fbbfb3ec55e22315e865769df5f715fa5
diff --git a/sci-biology/psychopy/psychopy-1.83.03.ebuild b/sci-biology/psychopy/psychopy-1.83.03.ebuild
new file mode 100644
index 000000000..c22a36877
--- /dev/null
+++ b/sci-biology/psychopy/psychopy-1.83.03.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2-utils distutils-r1
+
+DESCRIPTION="Python experimental psychology toolkit"
+HOMEPAGE="http://www.psychopy.org/"
+SRC_URI="https://github.com/psychopy/psychopy/releases/download/${PV}/${P}.zip"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[lapack,${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/wxpython:*[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ "
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newicon -s scalable psychopy/monitors/psychopy-icon.svg psychopy.svg
+ make_desktop_entry psychopyApp.py PsychoPy psychopy
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}