aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-01 09:12:20 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-01 09:12:20 +0100
commit86dd71ff4e5aaf1d07e78b746045ec800fe2bafe (patch)
tree30079b161579cca3a2591e2b572fa56750dd773c
parentsci-biology/MochiView: fix empty ebuild (diff)
downloadsci-86dd71ff4e5aaf1d07e78b746045ec800fe2bafe.tar.gz
sci-86dd71ff4e5aaf1d07e78b746045ec800fe2bafe.tar.bz2
sci-86dd71ff4e5aaf1d07e78b746045ec800fe2bafe.zip
sci-biology/SOAPdenovo2: version bump 242
no keywords yet, because it does not compile Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-biology/SOAPdenovo2/Manifest2
-rw-r--r--sci-biology/SOAPdenovo2/SOAPdenovo2-242.ebuild (renamed from sci-biology/SOAPdenovo2/SOAPdenovo2-241.ebuild)31
2 files changed, 14 insertions, 19 deletions
diff --git a/sci-biology/SOAPdenovo2/Manifest b/sci-biology/SOAPdenovo2/Manifest
index 047465b7e..f732ff7a8 100644
--- a/sci-biology/SOAPdenovo2/Manifest
+++ b/sci-biology/SOAPdenovo2/Manifest
@@ -1 +1 @@
-DIST SOAPdenovo2-241.tar.gz 1532760 BLAKE2B 3229ca63b8ecb5012cc8eaa16991ea1385c63da1d7b78c8a3ade6b5fe0b90be08c08d18d3f5e5d708e3af50d5a06e9413807b00e6512965fbc2b8b07ec2dcc6b SHA512 7b0cd992e437f9e5c6f4878c3d3b1fa93f3f8aa3d40895f88cc7a99f7cd69003c4db4d27d7aaa1c2f9f43741f048a74c2479aced44ce4b9432405195749af2e2
+DIST SOAPdenovo2-242.tar.gz 1534059 BLAKE2B e72b8b8005a807e1f949d092a1b582ed75ddbd3f4a1f014f86754ae69e279b93758693f36942e16183095fcfcc843a637fab39b08cfa6b8cbeffaf8b07c3050a SHA512 eaa2020aa9054588805bd69bb2e1d70be5bfcad31d52a33ed8f7accd4006db1ec980b20f846a6e1c0ee0ec8a493c38febb9022ce6a59c14d03fe43a3ca50569b
diff --git a/sci-biology/SOAPdenovo2/SOAPdenovo2-241.ebuild b/sci-biology/SOAPdenovo2/SOAPdenovo2-242.ebuild
index e3679664d..8ae80d466 100644
--- a/sci-biology/SOAPdenovo2/SOAPdenovo2-241.ebuild
+++ b/sci-biology/SOAPdenovo2/SOAPdenovo2-242.ebuild
@@ -1,19 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit toolchain-funcs eutils
+inherit toolchain-funcs
DESCRIPTION="Whole genome shotgun assembler (sparse de Bruijn graph) (now MEGAHIT)"
HOMEPAGE="https://github.com/aquaskyline/SOAPdenovo2
- http://gigascience.biomedcentral.com/articles/10.1186/2047-217X-1-18"
-SRC_URI="https://github.com/aquaskyline/SOAPdenovo2/archive/r241.tar.gz -> ${P}.tar.gz"
+ https://gigascience.biomedcentral.com/articles/10.1186/2047-217X-1-18"
+SRC_URI="https://github.com/aquaskyline/SOAPdenovo2/archive/r${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
-IUSE=""
+KEYWORDS="" # fails to compile
DEPEND="dev-libs/libaio
sci-biology/samtools:0.1-legacy"
@@ -22,7 +21,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}"/"${PN}"-r"${PV}" # version is 2.04-r241
src_prepare(){
- epatch "${FILESDIR}"/SOAPdenovo2-r241-Makefile.patch
+ #eapply "${FILESDIR}"/SOAPdenovo2-r241-Makefile.patch
# this will be partly covered by
# https://github.com/aquaskyline/SOAPdenovo2/pull/44
#
@@ -33,15 +32,11 @@ src_prepare(){
sparsePregraph/inc/sam.h sparsePregraph/inc/bam.h sparsePregraph/inc/bgzf.h standardPregraph/inc/zlib.h \
standardPregraph/inc/zconf.h sparsePregraph/inc/zlib.h sparsePregraph/inc/zconf.h standardPregraph/inc/*.so \
sparsePregraph/*.a || die
+ find -type f -name "*.h" -exec sed -i -e 's/#include "sam.h"/#include "bam-0.1-legacy\/sam.h"/g' {} + || die
+ find -type f -name "*.h" -exec sed -i -e 's/#include "bgzf.h"/#include "bam-0.1-legacy\/bgzf.h"/g' {} + || die
+ find -type f -name "*.h" -exec sed -i -e 's/#include "sam.h"/#include "bam-0.1-legacy\/sam.h"/g' {} + || die
+ find -type f -name "*.c*" -exec sed -i -e 's/#include "bam.h"/#include "bam-0.1-legacy\/bam.h"/g' {} + || die
+ find -type f -name "*.c*" -exec sed -i -e 's/#include "bgzf.h"/#include "bam-0.1-legacy\/bgzf.h"/g' {} + || die
+ find -type f -name "*.c*" -exec sed -i -e 's/#include "sam.h"/#include "bam-0.1-legacy\/sam.h"/g' {} + || die
default
}
-
-src_compile(){
- cd standardPregraph && emake -j1 63mer=1
- cd ../standardPregraph && emake -j1 127mer=1
- cd ../sparsePregraph && emake -j1
-}
-
-src_install(){
- doman "${FILESDIR}"/SOAPdenovo2.1
-}