aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-09-08 11:12:34 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-09-08 11:12:34 +0200
commit4912235ae628f7dcbfb9988813f168e737e05aba (patch)
tree29df4a961c8724229db56c49e19bb2f3a4c34f10 /dev-libs
parentsci-libs/arrayfire: Drop 0.9999, because releases are available (diff)
downloadsci-4912235ae628f7dcbfb9988813f168e737e05aba.tar.gz
sci-4912235ae628f7dcbfb9988813f168e737e05aba.tar.bz2
sci-4912235ae628f7dcbfb9988813f168e737e05aba.zip
dev-libs/boost-compute: Install includes to /usr/include/boost/compute
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost-compute/ChangeLog8
l---------dev-libs/boost-compute/boost-compute-0.4-r1.ebuild1
-rw-r--r--dev-libs/boost-compute/boost-compute-0.4-r2.ebuild28
-rw-r--r--dev-libs/boost-compute/boost-compute-9999.ebuild21
-rw-r--r--dev-libs/boost-compute/files/boost-compute-0.4-Fix-install-destination-of-headers.patch22
5 files changed, 65 insertions, 15 deletions
diff --git a/dev-libs/boost-compute/ChangeLog b/dev-libs/boost-compute/ChangeLog
index 1beef49b0..e7d434f0c 100644
--- a/dev-libs/boost-compute/ChangeLog
+++ b/dev-libs/boost-compute/ChangeLog
@@ -1,6 +1,14 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+*boost-compute-0.4-r2 (08 Sep 2015)
+
+ 08 Sep 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +boost-compute-0.4-r2.ebuild,
+ +files/boost-compute-0.4-Fix-install-destination-of-headers.patch,
+ -boost-compute-0.4-r1.ebuild, boost-compute-9999.ebuild:
+ dev-libs/boost-compute: Install includes to /usr/include/boost/compute
+
05 Jun 2015; Marius Brehler <marbre@linux.sungazer.de>
boost-compute-9999.ebuild, metadata.xml:
dev-libs/boost-compute: Update HOMEPAGE, SRC_URI and github remote-id: project
diff --git a/dev-libs/boost-compute/boost-compute-0.4-r1.ebuild b/dev-libs/boost-compute/boost-compute-0.4-r1.ebuild
deleted file mode 120000
index 9782d2a2f..000000000
--- a/dev-libs/boost-compute/boost-compute-0.4-r1.ebuild
+++ /dev/null
@@ -1 +0,0 @@
-boost-compute-9999.ebuild \ No newline at end of file
diff --git a/dev-libs/boost-compute/boost-compute-0.4-r2.ebuild b/dev-libs/boost-compute/boost-compute-0.4-r2.ebuild
new file mode 100644
index 000000000..bd588d253
--- /dev/null
+++ b/dev-libs/boost-compute/boost-compute-0.4-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="A header-only C++ Computing Library for OpenCL"
+HOMEPAGE="https://github.com/boostorg/compute"
+SRC_URI="https://github.com/boostorg/compute/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+S="${WORKDIR}/compute-${PV}"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}/${P}"-Fix-install-destination-of-headers.patch
+ "${FILESDIR}/${P}"-CMakeLists.patch
+)
+
+
+RDEPEND="
+ dev-libs/boost
+ virtual/opencl
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-libs/boost-compute/boost-compute-9999.ebuild b/dev-libs/boost-compute/boost-compute-9999.ebuild
index 93b8d7b87..f4c20598b 100644
--- a/dev-libs/boost-compute/boost-compute-9999.ebuild
+++ b/dev-libs/boost-compute/boost-compute-9999.ebuild
@@ -4,29 +4,22 @@
EAPI=5
-inherit eutils cmake-utils
+inherit eutils cmake-utils git-r3
DESCRIPTION="A header-only C++ Computing Library for OpenCL"
HOMEPAGE="https://github.com/boostorg/compute"
+EGIT_REPO_URI="https://github.com/boostorg/compute.git git://github.com/boostorg/compute.git"
+KEYWORDS=""
LICENSE="Boost-1.0"
SLOT="0"
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/boostorg/compute.git git://github.com/boostorg/compute.git"
- inherit git-r3
- KEYWORDS=""
-else
- SRC_URI="https://github.com/boostorg/compute/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/compute-${PV}"
-fi
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-0.4-Fix-install-destination-of-headers.patch
+)
RDEPEND="
dev-libs/boost
virtual/opencl
"
DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}"-0.4-CMakeLists.patch
-)
diff --git a/dev-libs/boost-compute/files/boost-compute-0.4-Fix-install-destination-of-headers.patch b/dev-libs/boost-compute/files/boost-compute-0.4-Fix-install-destination-of-headers.patch
new file mode 100644
index 000000000..c37ddd577
--- /dev/null
+++ b/dev-libs/boost-compute/files/boost-compute-0.4-Fix-install-destination-of-headers.patch
@@ -0,0 +1,22 @@
+From 3df0527cad686a4e9a3cd84ead97702cf8964da3 Mon Sep 17 00:00:00 2001
+From: Marius Brehler <marius.brehler@tu-dortmund.de>
+Date: Tue, 8 Sep 2015 10:35:56 +0200
+Subject: [PATCH] Fix install destination of headers
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3695681..56b47b6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -109,4 +109,4 @@ install(
+ )
+
+ # install header files
+-install(DIRECTORY include/boost DESTINATION include/compute)
++install(DIRECTORY include/boost DESTINATION include)
+--
+2.4.6
+