aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Gonçalves <camaradadennis@gmail.com>2023-09-02 11:23:32 -0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-09-05 13:05:28 +0200
commit73dbd35fdd9ad310ed136ad1bb5257ca0fad3e7a (patch)
treee2b13f28d9483a2f5bda5d78fe32d0ed493b39c6 /dev-python/geopandas/geopandas-0.13.2.ebuild
parentsci-biology/BEP032tools: new package, add 0.0.1_alpha (diff)
downloadsci-73dbd35fdd9ad310ed136ad1bb5257ca0fad3e7a.tar.gz
sci-73dbd35fdd9ad310ed136ad1bb5257ca0fad3e7a.tar.bz2
sci-73dbd35fdd9ad310ed136ad1bb5257ca0fad3e7a.zip
dev-python/geopandas: add 0.13.2, drop 0.12.2
Closes: https://github.com/gentoo/sci/pull/1217 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/geopandas/geopandas-0.13.2.ebuild')
-rw-r--r--dev-python/geopandas/geopandas-0.13.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/geopandas/geopandas-0.13.2.ebuild b/dev-python/geopandas/geopandas-0.13.2.ebuild
new file mode 100644
index 000000000..921c13417
--- /dev/null
+++ b/dev-python/geopandas/geopandas-0.13.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python tools for geographic data"
+HOMEPAGE="https://github.com/geopandas/geopandas https://pypi.org/project/geopandas/"
+SRC_URI="https://github.com/geopandas/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/shapely[${PYTHON_USEDEP}]
+ dev-python/fiona[${PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # needs network access
+ geopandas/io/tests/test_file.py::test_read_file_url
+ # fails with RuntimeError thrown by matplotlib
+ geopandas/tests/test_plotting.py::TestGeoplotAccessor::test_pandas_kind
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}
+
+pkg_postinst() {
+ optfeature "plotting" dev-python/matplotlib
+ optfeature "spatial indexes and spatial joins" sci-libs/rtree
+ optfeature "geocoding" sci-geosciences/geopy
+ optfeature "geodatabase access" dev-python/psycopg dev-python/sqlalchemy
+}