summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2014-12-14 12:04:39 +0100
committerThomas Sachau <tommy@gentoo.org>2014-12-14 12:04:39 +0100
commit1eff882acc89a4038e3da07d7fd326ff8f715ceb (patch)
tree41754122e8cf7ee78b53616809aeb4ef89195f6d /dev-python/openopt/openopt-0.43.ebuild
parentRemove dev-python/lazr-uri because of missing dependency: =dev-lang/python-2.6* (diff)
downloadsunrise-reviewed-1eff882acc89a4038e3da07d7fd326ff8f715ceb.tar.gz
sunrise-reviewed-1eff882acc89a4038e3da07d7fd326ff8f715ceb.tar.bz2
sunrise-reviewed-1eff882acc89a4038e3da07d7fd326ff8f715ceb.zip
Remove dev-python/openopt because of missing dependency: =dev-lang/python-2.5*
Diffstat (limited to 'dev-python/openopt/openopt-0.43.ebuild')
-rw-r--r--dev-python/openopt/openopt-0.43.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/openopt/openopt-0.43.ebuild b/dev-python/openopt/openopt-0.43.ebuild
deleted file mode 100644
index adde6a7af..000000000
--- a/dev-python/openopt/openopt-0.43.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_MODNAME="openopt"
-
-inherit distutils
-
-MY_PN="OpenOpt"
-
-DESCRIPTION="A python module for numerical optimization"
-HOMEPAGE="http://openopt.org"
-SRC_URI="http://openopt.org/images/3/33/${MY_PN}.zip -> ${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND="dev-python/numpy"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-S=${WORKDIR}/${MY_PN}
-
-src_prepare() {
- sed -i -e 's/find_packages()/find_packages(exclude=["openopt.examples", "openopt.tests"])/' setup.py || die
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/${PF}/examples
- doins -r openopt/examples/* || die
- fi
-}