summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/openopt/openopt-0.43.ebuild')
-rw-r--r--dev-python/openopt/openopt-0.43.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/openopt/openopt-0.43.ebuild b/dev-python/openopt/openopt-0.43.ebuild
deleted file mode 100644
index adde6a7af..000000000
--- a/dev-python/openopt/openopt-0.43.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_MODNAME="openopt"
-
-inherit distutils
-
-MY_PN="OpenOpt"
-
-DESCRIPTION="A python module for numerical optimization"
-HOMEPAGE="http://openopt.org"
-SRC_URI="http://openopt.org/images/3/33/${MY_PN}.zip -> ${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND="dev-python/numpy"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-S=${WORKDIR}/${MY_PN}
-
-src_prepare() {
- sed -i -e 's/find_packages()/find_packages(exclude=["openopt.examples", "openopt.tests"])/' setup.py || die
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/${PF}/examples
- doins -r openopt/examples/* || die
- fi
-}