summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2008-03-04 11:39:44 +0000
committerJakub Moc <jakub@gentoo.org>2008-03-04 11:39:44 +0000
commit8e66879bc96a67b3d9083665bef454ab7cdf5dc1 (patch)
tree3cd8bec72939e08a8107b6f53e7005bba293b2ff /mail-client/roundcube
parentVersion bump to 0.1 final; drop PEAR dependencies are they are now bundled an... (diff)
downloadwebapps-experimental-8e66879bc96a67b3d9083665bef454ab7cdf5dc1.tar.gz
webapps-experimental-8e66879bc96a67b3d9083665bef454ab7cdf5dc1.tar.bz2
webapps-experimental-8e66879bc96a67b3d9083665bef454ab7cdf5dc1.zip
Add some more PHP checks and info to pkg_setup.
svn path=/experimental/; revision=834
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/Manifest4
-rw-r--r--mail-client/roundcube/files/postinstall-en.txt6
-rw-r--r--mail-client/roundcube/roundcube-0.1.ebuild36
3 files changed, 34 insertions, 12 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 5e8fc0d..5f6a93d 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1,5 +1,5 @@
-AUX postinstall-en.txt 2716 RMD160 a3beacb799ebeb39840a6957609ad033b9ea2b7b SHA1 28383ab1ef42ab3a0b557b3c4795d1362c753155 SHA256 5b8fa40c56f44bfb66230927d31e7b9207c53b03662c0867e3190eca77250365
+AUX postinstall-en.txt 2728 RMD160 29c43129c0fab73b7d6950702b3f40debe4285d5 SHA1 d03fd62f5152e0a97679329d985712858ef10a77 SHA256 e40f6366decaaeeb4e8085fe735ea42df47c2a9516a045680ebdfe10feb98fa9
DIST roundcubemail-0.1.tar.gz 1406854 RMD160 225b3a37c70bcf3b471b7d650233aec30dae2f76 SHA1 8b5b516b41bad98c3bbaf0da0e70b0db82580424 SHA256 ea4f4b23b9a20308cc0b1fef3b7301700c9ce4544189007bc62756e8d5f67051
-EBUILD roundcube-0.1.ebuild 1729 RMD160 c28f3d5a13543349809174ef4b8d313f28a4a039 SHA1 59cc1bdd0017e1d5957c6cb257c83bafd0c8a3a8 SHA256 a4325a05b4cb5fdccbfe613506ebab2cf36c328c3a7d42a7ef08df5f6ff5bc05
+EBUILD roundcube-0.1.ebuild 2715 RMD160 634b01f4af980926aaaae867a2ed5626cc840525 SHA1 1637513ad5cd716a489e127fb58512913079b539 SHA256 51125baf58a177ea5e095e531f6c167bf0ea826fd3df4ca3b40171124d7b8cff
MISC ChangeLog 1296 RMD160 0a4e900dab53bea9b7f878d2a52918005ac512a6 SHA1 099bd3cfd98c3fbc7377fd4ca5921233850ce263 SHA256 1dd26ed4a53d53235672252354f8c43570491cb8c3fb3a7ffade0ff50fb8eb1f
MISC metadata.xml 162 RMD160 0b015f5ff17c4d8e7aee826d48b326cc19b1fed4 SHA1 671b30dafbea01228c8bb606af451a0795922840 SHA256 84ff2fc6c9a4af1b9dbe32aa81ab84c2958bc1bd65a9977686df2dcab6e420d0
diff --git a/mail-client/roundcube/files/postinstall-en.txt b/mail-client/roundcube/files/postinstall-en.txt
index 192ff54..630875c 100644
--- a/mail-client/roundcube/files/postinstall-en.txt
+++ b/mail-client/roundcube/files/postinstall-en.txt
@@ -63,9 +63,11 @@ See http://trac.roundcube.net/wiki/Howto_Install for even more guidance.
2. PHP CONFIGURATION
- error_reporting E_ALL & ~E_NOTICE (or lower)
- - file_uploads on (for attachment upload features)
+ - file_uploads On (for attachment upload features)
+ - session.auto_start Off
+ - magic_quotes_gpc Off
- memory_limit (increase as suitable to support large attachments)
- - session.auto_start needs to be off/0
+
3. WEBSERVER CONFIGURATION
diff --git a/mail-client/roundcube/roundcube-0.1.ebuild b/mail-client/roundcube/roundcube-0.1.ebuild
index 995f8cb..1ddefb0 100644
--- a/mail-client/roundcube/roundcube-0.1.ebuild
+++ b/mail-client/roundcube/roundcube-0.1.ebuild
@@ -11,32 +11,52 @@ HOMEPAGE="http://www.roundcube.net"
SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
# roundcube is GPL-licensed, the rest of the licenses here are
-# for bundled PEAR components and utf8.class.php
-LICENSE="GPL-2 BSD PHP-2.02 PHP-3 public-domain"
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
KEYWORDS="~amd64 ~x86"
-IUSE="mysql postgres sqlite ssl"
+IUSE="ldap mysql postgres sqlite ssl spell"
+RDEPEND="dev-php/PEAR-PEAR"
need_httpd_cgi
need_php_httpd
S="${WORKDIR}/${MY_P}"
pkg_setup() {
- local flags="crypt iconv imap pcre unicode"
+ local flags="crypt iconv imap pcre session socket unicode"
+ use ldap && flags="${flags} ldap"
use ssl && flags="${flags} ssl"
- use spell && flags="${flags} curl socket"
- local dbflags="mysql postgres sqlite"
+ use spell && flags="${flags} curl ssl"
+
+ # check for required PHP features
if ! use mysql && ! use postgres && ! use sqlite ; then
+ local dbflags="mysql mysqli postgres sqlite"
if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
! PHPCHECKNODIE="yes" require_php_with_any_use ${dbflags} ; then
die "Re-install ${PHP_PKG} with ${flags} and at least one of ${dbflags} in USE."
fi
else
- for db in ${dbflags} ; do
+ for db in postgres sqlite ; do
use ${db} && flags="${flags} ${db}"
done
- require_php_with_use ${flags}
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ( use mysql && ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ) ; then
+ local diemsg="Re-install ${PHP_PKG} with ${flags}"
+ use mysql && diemsg="${diemsg} and at least one of mysql mysqli"
+ die "${diemsg} in USE"
+ fi
fi
+
+ # add some warnings about optional functionality
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ ewarn "IMAP quota display will not work correctly without GD support in PHP."
+ ewarn "Recompile PHP with either gd or gd-external in USE if you want this feature."
+ ewarn
+ fi
+ use ldap || ewarn "PHP with USE=\"ldap\" is required for using LDAP addressbooks."
+ use ssl || ewarn "PHP with USE=\"ssl\" is required for IMAPS/STMPS functionality."
+ use spell || ewarn "PHP with USE=\"curl ssl\" required for spellchecker functionality."
+
webapp_pkg_setup
}