summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-10-08 10:42:16 +0200
committerUlrich Müller <ulm@gentoo.org>2021-10-08 10:42:41 +0200
commit016bcebec76fa373428c3c50d7477da941e5dccc (patch)
treea117d6de8a0f2b70757c5d4722a3c40d7d7eb051
parentapp-emacs/yasnippet: Version bump to 0.14.0 (diff)
downloadgentoo-016bcebe.tar.gz
gentoo-016bcebe.tar.bz2
gentoo-016bcebe.zip
app-emacs/yasnippet-snippets: Version bump to 1.0
Closes: https://bugs.gentoo.org/816936 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-emacs/yasnippet-snippets/Manifest1
-rw-r--r--app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/yasnippet-snippets/Manifest b/app-emacs/yasnippet-snippets/Manifest
index 50e0de93d6f0..ec79306a543b 100644
--- a/app-emacs/yasnippet-snippets/Manifest
+++ b/app-emacs/yasnippet-snippets/Manifest
@@ -1 +1,2 @@
DIST yasnippet-snippets-0.3.tar.gz 97229 BLAKE2B 26fe83c35be1b20b6a1e414144149cf1feaf4463833634bbd0a3db6f56b1da46d8e379c3dd19217cfd36f12cb9dc796eac4efef5c2ba472ce79f8c8b8d816969 SHA512 4aaac9d7c880642a1e802abb98bd6d6c94557fe0e609db5ce5b4ce2af921235d3e6bb2488c052adbe2940d41e85297520081ae0847b52642bc97610e6614727f
+DIST yasnippet-snippets-1.0.tar.gz 178027 BLAKE2B 0b44c94c3ad3f2a1208aefba110945aeae74e7278c93078c59677985efc89767b670c99b4b8303b56ea0b748375762ada1e45653e02922b248273af5818514d4 SHA512 2df010f24e51d0156bcb3d488cd6a63a47d2d92e4c5f3cd081e377dc91426d630bde41db6f79d1b5ac1e932e4d0ab11f9be945e94fb35d50b1789adab19bd15b
diff --git a/app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild b/app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild
new file mode 100644
index 000000000000..3b0d29b244e7
--- /dev/null
+++ b/app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A collection of yasnippet snippets for many languages"
+HOMEPAGE="https://github.com/AndreaCrotti/yasnippet-snippets"
+SRC_URI="https://github.com/AndreaCrotti/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/yasnippet"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() { :; }
+
+src_install() {
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ insinto "${SITEETC}/${PN}"
+ doins -r snippets/.
+ dodoc README.md
+}