summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-13 10:49:55 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-13 12:54:38 +0100
commit02e28e92b7be406bc004efc87fd72bee16622528 (patch)
treeb1c2242f4eb26513417d7a02fde08dd6ca4bd4eb
parentdev-python/botocore: Bump to 1.19.53 (diff)
downloadgentoo-02e28e92b7be406bc004efc87fd72bee16622528.tar.gz
gentoo-02e28e92b7be406bc004efc87fd72bee16622528.tar.bz2
gentoo-02e28e92b7be406bc004efc87fd72bee16622528.zip
dev-python/boto3: Bump to 1.16.53
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.53.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index a7939a12b561..a6dc7e3de373 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.16.43.tar.gz 342444 BLAKE2B 1a367fa252eab6738533c7bec2bc370dcc206f2
DIST boto3-1.16.50.tar.gz 342744 BLAKE2B a6581acbdb07f2d8ce21ddf384b471d281d58910366dee0669f0f726118eabd52de8a4fe129915b9044bd484950155c32fa4f4941e1ef6ce55249213ba29f2f3 SHA512 de483be833917a2c478c0fe651ffe4143dc6c742e259711a955be41a8b76197353b295526695ca800bb860b95e0378dc461119bfa163c4be0faa3b6c2ccfc097
DIST boto3-1.16.51.tar.gz 342794 BLAKE2B e344c4a2c6b1c43e0f2f9207541a7e00963829f9398cb36ab8a90544a486a638d2f88552fde5b006388692463de6c93fec6b16a64e43874fc173f82af3d8272c SHA512 5bd66801121aff3526d742dd79b48b1d502b76c0319183660d22532a5abb31b6faf616ddb2af774519e8e5eb89616be85e478325497ed6af8635e02786d0c78f
DIST boto3-1.16.52.tar.gz 342838 BLAKE2B 62ab3b2bd72369e08d514fb712eb6653c247e774fbfb579f1293ec1a42752d7321011cf75a054cd625846e72b1b5b6490b1d8bd48f5a2ed818fcf6ac060c0857 SHA512 6a80ee0181f5def2595e7a2d07e7a29e32c23b2d91908338c43fc4794be3d69504cdf8cec7372cdca09004dddb45ae49772404f59a222af4e3eb0bb869cdaf98
+DIST boto3-1.16.53.tar.gz 342896 BLAKE2B 28f3fde4e029944d839c9bb46f8d0e0603dc1dc890cd157ade2687a5566b00ae77ef19c0835341cf92d12b8fca2d5290508456f1938789aa2689ac7a5673550e SHA512 f73cc6b78fdeedd25c7976ab1df681dce438bfe40f03cf74a3bbdb1d0b54b4203d650cd72263325fd9f1dbbb60445dfeb619c070debf711da7ab696eacd5a464
diff --git a/dev-python/boto3/boto3-1.16.53.ebuild b/dev-python/boto3/boto3-1.16.53.ebuild
new file mode 100644
index 000000000000..7be6516ff810
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.53.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}