summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-06 22:21:35 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-06 23:47:13 +0100
commit037a713550a6e413a9f4c716c2e6fdacf8fc8a64 (patch)
treea14ebf0f070b5c20a7d176a3b2b0d3fe289fb6d7
parentapp-emacs/tempel: drop old 0.7 (diff)
downloadgentoo-037a713550a6e413a9f4c716c2e6fdacf8fc8a64.tar.gz
gentoo-037a713550a6e413a9f4c716c2e6fdacf8fc8a64.tar.bz2
gentoo-037a713550a6e413a9f4c716c2e6fdacf8fc8a64.zip
app-emacs/tempel: bump to 1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/tempel/Manifest1
-rw-r--r--app-emacs/tempel/tempel-1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/tempel/Manifest b/app-emacs/tempel/Manifest
index 209d22ce80f8..2004a47539c0 100644
--- a/app-emacs/tempel/Manifest
+++ b/app-emacs/tempel/Manifest
@@ -1 +1,2 @@
DIST tempel-0.8.tar.gz 27043 BLAKE2B f4920a1c0d1d7ed21f2681031f846b07fcdabbd59b76f3ba2fcd1277c78b30e1c5e134deeb35410f7227d753256b9c16c6a4d641011b99d87b49f0fae0fd5a04 SHA512 7b832e151821f4c72a3d14663fb76a956e2b6730387e71e1aedb52c72a7798a5804ad2ca3d63185c52d39128d748394419c3708d8a6a7497014e573d277fa5d9
+DIST tempel-1.0.tar.gz 27311 BLAKE2B 65ae51725e3022a9b893bd2cd4d592186c647e04b6bd28af06af1e3a501165dc9d53ff5758292330ffa8120b3e128abfb27fe275bdd8eb69d549dc0f06a9e512 SHA512 f07ea90098181d7331ac5ace2f53defa8b10be72c5962848c3738f69fbf3f56a8faeaf8de3a542eba1f88d63bc489cca653363b9aab4085d11464e59e3f0bbeb
diff --git a/app-emacs/tempel/tempel-1.0.ebuild b/app-emacs/tempel/tempel-1.0.ebuild
new file mode 100644
index 000000000000..8a32fe684d94
--- /dev/null
+++ b/app-emacs/tempel/tempel-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Templates with in-buffer field editing for GNU Emacs"
+HOMEPAGE="https://github.com/minad/tempel/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.3.4"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}