summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-12 23:37:20 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-13 01:23:15 +0200
commit04ca9788d56bacdb82221031dd4de51ba6a07532 (patch)
treecf40b57773415439c70141f47c5671c461d20506
parentmedia-fonts/spleen: new package; add 2.0.0 (diff)
downloadgentoo-04ca9788d56bacdb82221031dd4de51ba6a07532.tar.gz
gentoo-04ca9788d56bacdb82221031dd4de51ba6a07532.tar.bz2
gentoo-04ca9788d56bacdb82221031dd4de51ba6a07532.zip
dev-util/datree: new package; add 1.9.19
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-util/datree/Manifest2
-rw-r--r--dev-util/datree/datree-1.9.19.ebuild54
-rw-r--r--dev-util/datree/metadata.xml19
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-util/datree/Manifest b/dev-util/datree/Manifest
new file mode 100644
index 000000000000..5a58be64cc27
--- /dev/null
+++ b/dev-util/datree/Manifest
@@ -0,0 +1,2 @@
+DIST datree-1.9.19-deps.tar.xz 76454516 BLAKE2B ddce1505465c2317d52e9c64a0672f8b80e5f2d7dda51279acb624719292c2f6fc1b97c3ab2c3b0e7497a0c20014166afbaf1ba0e1d788ac989c4c0fd6bac140 SHA512 26941c5fedcbaed680a29b81e786a45e89b69e45729c538907718985c17b438fa2079995e3e670107ff23d7bb29d38579b2f9cada20909b2d166c45a782aab9e
+DIST datree-1.9.19.tar.gz 5792718 BLAKE2B 564b3194e424c5396950e4f03ae7c27f9b477afaca4c1f0604202b0f15349307e5f3f70c431227b1e6fcd45f4d323cc3cf990cc12798ccc8887faddf3a1f89dd SHA512 2f962385881d3f5e9a26c2a10c9930c19c090efa2b2ec240610a6cb42a51cc986d3eda92324022cf10f2e583fceadd2d81bb93f7bcddd4cf4b3e871da5d16bdc
diff --git a/dev-util/datree/datree-1.9.19.ebuild b/dev-util/datree/datree-1.9.19.ebuild
new file mode 100644
index 000000000000..9444d2a9e96c
--- /dev/null
+++ b/dev-util/datree/datree-1.9.19.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo go-module shell-completion
+
+DESCRIPTION="Tool to ensure K8s manifests and Helm charts follow best practices"
+HOMEPAGE="https://hub.datree.io/
+ https://github.com/datreeio/datree/"
+SRC_URI="
+ https://github.com/datreeio/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md examples )
+
+src_compile() {
+ local go_ldflags="
+ -s
+ -w
+ -X github.com/datreeio/datree/cmd.CliVersion=${PV}
+ "
+ local -a go_buildargs=(
+ -ldflags "${go_ldflags}"
+ )
+ ego build "${go_buildargs[@]}"
+
+ local -a shell_types=(
+ bash
+ fish
+ zsh
+ )
+ local shell_type
+ for shell_type in ${shell_types[@]} ; do
+ edo ./datree completion ${shell_type} > ${PN}.${shell_type}
+ done
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe ${PN}
+
+ dofishcomp ${PN}.fish
+ newbashcomp ${PN}.bash ${PN}
+ newzshcomp ${PN}.zsh _${PN}
+
+ einstalldocs
+}
diff --git a/dev-util/datree/metadata.xml b/dev-util/datree/metadata.xml
new file mode 100644
index 000000000000..dfc2cb26d345
--- /dev/null
+++ b/dev-util/datree/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Datree provides an E2E policy enforcement solution to run automatic checks
+ for rule violations. Datree can be used on the command line, admission
+ webhook, or even as a kubectl plugin to run policies against Kubernetes
+ objects.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/datreeio/datree/issues</bugs-to>
+ <remote-id type="github">datreeio/datree</remote-id>
+ </upstream>
+</pkgmetadata>