summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-01-25 22:41:59 +0530
committerZac Medico <zmedico@gentoo.org>2024-02-01 22:37:26 -0800
commit04daa352b1a9a4c131d70782dc5cfed27b6fa5a8 (patch)
treea75384adca796191ea3a6d56d40ac8238c833fe3
parentapp-containers/netavark: add 1.10.2 (diff)
downloadgentoo-04daa352b1a9a4c131d70782dc5cfed27b6fa5a8.tar.gz
gentoo-04daa352b1a9a4c131d70782dc5cfed27b6fa5a8.tar.bz2
gentoo-04daa352b1a9a4c131d70782dc5cfed27b6fa5a8.zip
app-containers/skopeo: add 1.14.2
sync coding style in line with 1.14.0-r3 Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-containers/skopeo/Manifest1
-rw-r--r--app-containers/skopeo/skopeo-1.14.2.ebuild69
-rw-r--r--app-containers/skopeo/skopeo-9999.ebuild50
3 files changed, 89 insertions, 31 deletions
diff --git a/app-containers/skopeo/Manifest b/app-containers/skopeo/Manifest
index 1af3899b804d..570f95b9e81f 100644
--- a/app-containers/skopeo/Manifest
+++ b/app-containers/skopeo/Manifest
@@ -1,4 +1,5 @@
DIST skopeo-1.10.0.tar.gz 6460856 BLAKE2B b904a161334ef0a3eaaab8c58f0c7e4c507fa68a09f8fa8235e8a9222d48c98874c9ce878a509e2816f210ffb37dbf707ff2653212e1efbd9ad6686efb97e147 SHA512 0d64e7f12a0d10c81074a04b6c74ed6e7213f598013f1ba672c4c696e9dad5827f41f41bb817263bf8606cd051b8e24e7eab65b95d73d8a1c8bbb3eaeb9defdb
DIST skopeo-1.11.1.tar.gz 8071084 BLAKE2B 2411db318e377cfcfa9a80523c0bd4900201b1c17a4fe0f875dd78033bd4241e6c806816746ef77304e2edbc3737a3b22cfa83b83d65eb3c462cd5437de4e0b8 SHA512 521a2c8ddf629e361340a51d95200ec67bc4fef814e0449b6d679725536ec9448827229d4f993276f084269c2ec73c1b4edf97c0ce29122d950d350ed623a4b9
DIST skopeo-1.14.0.tar.gz 10548883 BLAKE2B 6ecf54d236405ce59bedf77acc124fa8b3bb12acefa24a679a1d2d85957ddf585b5a6ba163806b8b7b510485d936adbe1afd6eee8c92b267b948f7d78ac83d05 SHA512 59d329036a97cbeca4de20b15d9dd8adacd5201834b26ae5e5c88b05594b2a7101c22da91f22c35c07a98e41afa28f2c7103e660b3847c7f8c9691f27f4c4146
+DIST skopeo-1.14.2.tar.gz 10547979 BLAKE2B bca47d82380ad714397dc8e36e365a3e81fc628b47519b022ecb5edd2a03ce8972c066af350cd1f0b5a3d9d6c1585f0729b32a1a829cfc4eaefc1c7fc9dc2667 SHA512 ffb3c00cdde05f7a916bd3980c9cec1bb82b3f3bf90058bfff1837d3a9902087ac011828e6164baec18210d4aeee1a5258b75405411fd15ea2470a2522a6da73
DIST skopeo-1.5.1.tar.gz 5636533 BLAKE2B 7f0e86cdee5c3250ec1280d7e71554ac2f8ad96ababe0e81dfabc00e8c128a13fc0c9c561b7a9be389d7386e9f664b95118bd2122612b9c2e8844db49769c03c SHA512 3f8c730eaa739bf2a29b82d3b04aa4eee1c09f957b61964fc8c48e59d1537bcb87b5bdf9c18fa48f9d36cf2b7ede3a1448918a20b5a3167f6ce09881a6cd3dde
diff --git a/app-containers/skopeo/skopeo-1.14.2.ebuild b/app-containers/skopeo/skopeo-1.14.2.ebuild
new file mode 100644
index 000000000000..ab892d6789a8
--- /dev/null
+++ b/app-containers/skopeo/skopeo-1.14.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module linux-info
+
+DESCRIPTION="Work with remote container images registries"
+HOMEPAGE="https://github.com/containers/skopeo"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/skopeo.git"
+else
+ SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+# main
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
+SLOT="0"
+IUSE="btrfs device-mapper rootless"
+
+COMMON_DEPEND="
+ >=app-crypt/gpgme-1.5.5:=
+ >=dev-libs/libassuan-2.4.3:=
+ btrfs? ( >=sys-fs/btrfs-progs-4.0.1 )
+ device-mapper? ( >=sys-fs/lvm2-2.02.145:= )
+ rootless? ( sys-apps/shadow:= )
+"
+
+# TODO: Is this really needed? cause upstream doesnt mention it https://github.com/containers/skopeo/blob/main/install.md#building-from-source
+# dev-libs/libgpg-error:=
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="
+ ${COMMON_DEPEND}
+ app-containers/containers-common
+"
+BDEPEND="dev-go/go-md2man"
+
+RESTRICT="test"
+
+pkg_setup() {
+ use btrfs && CONFIG_CHECK+=" ~BTRFS_FS"
+ use device-mapper && CONFIG_CHECK+=" ~MD"
+ linux-info_pkg_setup
+}
+
+run_make() {
+ emake \
+ BTRFS_BUILD_TAG="$(usex btrfs '' 'btrfs_noversion exclude_graphdriver_btrfs')" \
+ CONTAINERSCONFDIR="${EPREFIX}/etc/containers" \
+ LIBDM_BUILD_TAG="$(usex device-mapper '' 'libdm_no_deferred_remove exclude_graphdriver_devicemapper')" \
+ LIBSUBID_BUILD_TAG="$(usex rootless 'libsubid' '')" \
+ PREFIX="${EPREFIX}/usr" \
+ $@
+}
+
+src_compile() {
+ run_make all completions
+}
+
+src_install() {
+ # The install target in the Makefile tries to rebuild the binary and
+ # installs things that are already installed by containers-common.
+ dobin bin/skopeo
+ einstalldocs
+ doman docs/*.1
+ run_make "DESTDIR=${D}" install-completions
+}
diff --git a/app-containers/skopeo/skopeo-9999.ebuild b/app-containers/skopeo/skopeo-9999.ebuild
index b7a859d817d5..ab892d6789a8 100644
--- a/app-containers/skopeo/skopeo-9999.ebuild
+++ b/app-containers/skopeo/skopeo-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -38,9 +38,6 @@ RDEPEND="
BDEPEND="dev-go/go-md2man"
RESTRICT="test"
-PATCHES=(
- "${FILESDIR}"/makefile-1.14.0.patch
-)
pkg_setup() {
use btrfs && CONFIG_CHECK+=" ~BTRFS_FS"
@@ -48,34 +45,25 @@ pkg_setup() {
linux-info_pkg_setup
}
-src_prepare() {
- default
- local file
- for file in btrfs_installed_tag btrfs_tag libdm_tag libsubid_tag; do
- [[ -f hack/"${file}".sh ]] || die
- done
-
- echo -e "#!/usr/bin/env bash\n echo" > hack/btrfs_installed_tag.sh || die
- cat <<-EOF > hack/btrfs_tag.sh || die
- #!/usr/bin/env bash
- $(usex btrfs echo 'echo exclude_graphdriver_btrfs btrfs_noversion')
- EOF
-
- cat <<-EOF > hack/libdm_tag.sh || die
- #!/usr/bin/env bash
- $(usex device-mapper echo "echo libdm_no_deferred_remove exclude_graphdriver_devicemapper")
- EOF
-
- cat <<-EOF > hack/libsubid_tag.sh || die
- #!/usr/bin/env bash
- $(usex rootless "echo libsubid" echo)
- EOF
+run_make() {
+ emake \
+ BTRFS_BUILD_TAG="$(usex btrfs '' 'btrfs_noversion exclude_graphdriver_btrfs')" \
+ CONTAINERSCONFDIR="${EPREFIX}/etc/containers" \
+ LIBDM_BUILD_TAG="$(usex device-mapper '' 'libdm_no_deferred_remove exclude_graphdriver_devicemapper')" \
+ LIBSUBID_BUILD_TAG="$(usex rootless 'libsubid' '')" \
+ PREFIX="${EPREFIX}/usr" \
+ $@
}
src_compile() {
- # export variables which 'make install' is also going to use
- export PREFIX="${EPREFIX}/usr" \
- CONTAINERSCONFDIR="${EPREFIX}/etc/containers"
- # compile binary, docs, completions
- emake all completions
+ run_make all completions
+}
+
+src_install() {
+ # The install target in the Makefile tries to rebuild the binary and
+ # installs things that are already installed by containers-common.
+ dobin bin/skopeo
+ einstalldocs
+ doman docs/*.1
+ run_make "DESTDIR=${D}" install-completions
}