summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2019-02-04 20:36:40 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2019-02-04 20:36:40 +0100
commit089d5f82349c520157450cc4b80c8d3c3e4b7e7c (patch)
tree7585a5da9f4aa1dd810ab60404549e7ed340b39a
parentmedia-libs/mesa: Drop support for llvm < 7 (diff)
downloadgentoo-089d5f82.tar.gz
gentoo-089d5f82.tar.bz2
gentoo-089d5f82.zip
gnome-extra/libgsf: version bump
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
-rw-r--r--gnome-extra/libgsf/Manifest1
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.45.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/Manifest b/gnome-extra/libgsf/Manifest
index e097abb676c1..5a4594eb6509 100644
--- a/gnome-extra/libgsf/Manifest
+++ b/gnome-extra/libgsf/Manifest
@@ -1 +1,2 @@
DIST libgsf-1.14.43.tar.xz 618272 BLAKE2B a381125ce75d06ae4bf1c9dbe9b2e207534ff7c3310e40984e482bc5120eae45a7e3ed4cfd878890037f31ee540c700dea3120119b9a533fa79cab317a0c83a8 SHA512 bb487de9358c057fc73f3414c9515726315be9b6d78456253daaca1cbd58281de8766e0b72914532d63fab04d3ae2cf90f711f436c7b4f70620d77e8a7802ac9
+DIST libgsf-1.14.45.tar.xz 618476 BLAKE2B f577859578de6ca359a7377dcced424e95779d3fd155cdbeb1c2874f7a0d0c7a09a2322d2538452b48798ea979e8260be77215140f298dc58ee32a0b9ead0e47 SHA512 2e993150b6fec336a14fd85d5c631e4a3b43187039dab0cba3b8badf62873f39814392db92bb737b92aa9a6d8b4ba41f1fb248c1fe07b88cddd28ded5e4d9ebd
diff --git a/gnome-extra/libgsf/libgsf-1.14.45.ebuild b/gnome-extra/libgsf/libgsf-1.14.45.ebuild
new file mode 100644
index 000000000000..331e37c87816
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.45.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://developer.gnome.org/gsf/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ virtual/imagemagick-tools
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35.0
+ dev-libs/gobject-introspection-common
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}