summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-05 12:21:37 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-05 15:34:15 +0100
commit09453aaf12fc76ee597c76a31e5986474f64661f (patch)
tree1e46c39c8a974ed6591455328ede7c79aec97cff
parentdev-python/pytest-sugar: Bump to 0.9.6 (diff)
downloadgentoo-09453aaf.tar.gz
gentoo-09453aaf.tar.bz2
gentoo-09453aaf.zip
dev-python/xarray: Bump to 2022.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/xarray/Manifest1
-rw-r--r--dev-python/xarray/xarray-2022.11.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index f910dc689a2d..840bb51dfbe4 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,2 +1,3 @@
DIST xarray-2022.10.0.tar.gz 3035596 BLAKE2B f42df85bdfa66403826fc7d2fa811419898134723ee24afc6b77a320b23c9b5b95fcfd25520f74abf0a3b7bf009fdc33655eebf0ff9703753872072515deee58 SHA512 ecfc92c68ea7ba02b673c6c317e68daad23b6882b4ed316ad1dd733f179c643411d3ee5902954dbd62f2eb7ad591d8ba1a5f0c1b2c7f6873e733df2f22b6650c
+DIST xarray-2022.11.0.tar.gz 3053924 BLAKE2B 5e747aeda92ecb5a3ee2ce7a180cd8f3c2735b32d219f567fd254c733f98c62305829be166ddd76a3d2cd884f78aa3e6ceb2cf5aaac8539290c5863d5dea038d SHA512 6dc98746e3bea17a224926e7e1cf6a5f5ef01e8a848c63f5acd43f9da63b81093a7bdbebecb2afc06c9473d1b8fe735c67a847d05f25edd0a32bc0a5a2eda753
DIST xarray-2022.9.0.tar.gz 3030815 BLAKE2B 71bea98d49fa9ce2e8e881bdcba7872293e1cd9fa4bd23e6cdce40220d87550fade52a7b7c25ff5d0b11b8a729c57ed219031b1f13d1f375c5278ecc611dfbc5 SHA512 57383cfc809b26d743c06eb5a158d318c65aedfa374e62b0a5fdc99708632a364b2efb6275fbc728e441effb7c695635a443cf141d69fa742216a677f4168b3b
diff --git a/dev-python/xarray/xarray-2022.11.0.ebuild b/dev-python/xarray/xarray-2022.11.0.ebuild
new file mode 100644
index 000000000000..5e56abd493ea
--- /dev/null
+++ b/dev-python/xarray/xarray-2022.11.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="https://xarray.pydata.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.0[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+)