summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-12 21:28:33 +0100
committerSam James <sam@gentoo.org>2022-09-12 21:28:33 +0100
commit0a8dffa398fcbd459916ca331da9cb713372616a (patch)
treee9b19c8dd5f98b82cac61cb2c3ecd3cedbddc372
parentapp-shells/zsh: fix configure tests with Clang 15 (diff)
downloadgentoo-0a8dffa398fcbd459916ca331da9cb713372616a.tar.gz
gentoo-0a8dffa398fcbd459916ca331da9cb713372616a.tar.bz2
gentoo-0a8dffa398fcbd459916ca331da9cb713372616a.zip
net-misc/openssh: work around Clang 15 miscompilation with -fzero-call-used-regs=all
Bug: https://github.com/llvm/llvm-project/issues/57692 Bug: https://bugs.gentoo.org/869839 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/openssh/openssh-9.0_p1-r4.ebuild (renamed from net-misc/openssh/openssh-9.0_p1-r3.ebuild)4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-misc/openssh/openssh-9.0_p1-r3.ebuild b/net-misc/openssh/openssh-9.0_p1-r4.ebuild
index fb65bd3d8b54..4f44fcf80e97 100644
--- a/net-misc/openssh/openssh-9.0_p1-r3.ebuild
+++ b/net-misc/openssh/openssh-9.0_p1-r4.ebuild
@@ -326,6 +326,10 @@ src_configure() {
myconf+=( --disable-utmp --disable-wtmp )
fi
+ # Workaround for Clang 15 miscompilation with -fzero-call-used-regs=all
+ # bug #869839 (https://github.com/llvm/llvm-project/issues/57692)
+ tc-is-clang && myconf+=( --without-hardening )
+
econf "${myconf[@]}"
}