summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/openssh/openssh-9.0_p1-r4.ebuild (renamed from net-misc/openssh/openssh-9.0_p1-r3.ebuild)4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-misc/openssh/openssh-9.0_p1-r3.ebuild b/net-misc/openssh/openssh-9.0_p1-r4.ebuild
index fb65bd3d8b54..4f44fcf80e97 100644
--- a/net-misc/openssh/openssh-9.0_p1-r3.ebuild
+++ b/net-misc/openssh/openssh-9.0_p1-r4.ebuild
@@ -326,6 +326,10 @@ src_configure() {
myconf+=( --disable-utmp --disable-wtmp )
fi
+ # Workaround for Clang 15 miscompilation with -fzero-call-used-regs=all
+ # bug #869839 (https://github.com/llvm/llvm-project/issues/57692)
+ tc-is-clang && myconf+=( --without-hardening )
+
econf "${myconf[@]}"
}