summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 19:34:16 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commit0d3e543af797279950f6b5547bcf5b52532be4f3 (patch)
tree1d8c6040ba01aba59646f88b66d7cf0c0aba3516
parentdev-ml/ppx_enumerate: intiial import; ebuild by me (diff)
downloadgentoo-0d3e543af797279950f6b5547bcf5b52532be4f3.tar.gz
gentoo-0d3e543af797279950f6b5547bcf5b52532be4f3.tar.bz2
gentoo-0d3e543af797279950f6b5547bcf5b52532be4f3.zip
dev-ml/ppx_typerep_conv: initial import; ebuild by me
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ml/ppx_typerep_conv/Manifest1
-rw-r--r--dev-ml/ppx_typerep_conv/metadata.xml8
-rw-r--r--dev-ml/ppx_typerep_conv/ppx_typerep_conv-113.24.00.ebuild43
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-ml/ppx_typerep_conv/Manifest b/dev-ml/ppx_typerep_conv/Manifest
new file mode 100644
index 000000000000..ad82426f10e1
--- /dev/null
+++ b/dev-ml/ppx_typerep_conv/Manifest
@@ -0,0 +1 @@
+DIST ppx_typerep_conv-113.24.00.tar.gz 56449 SHA256 d106b1b400c73d484c1f1f28009c8952cc6abcb71de483ab170b04a31efb009c SHA512 c84f4f61a47965f6df491cde2f3d13d48e3b0d2badfc7a90a299370dfafea5c7b79ea02418800fc3871958d8f5b78aac96a1c86e56b6dafc8e9edc08ff10146e WHIRLPOOL 6bd77599ab66a9daf7506218c43bf5866e0e3c0892f3c8c1fca14396b110e6050b4e9a4105f34940e28119852be4e88581a1f8b650a8b1a04e2b8b2207f84da1
diff --git a/dev-ml/ppx_typerep_conv/metadata.xml b/dev-ml/ppx_typerep_conv/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/ppx_typerep_conv/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ppx_typerep_conv/ppx_typerep_conv-113.24.00.ebuild b/dev-ml/ppx_typerep_conv/ppx_typerep_conv-113.24.00.ebuild
new file mode 100644
index 000000000000..b6501cc92389
--- /dev/null
+++ b/dev-ml/ppx_typerep_conv/ppx_typerep_conv-113.24.00.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Generation of runtime types from type declarations"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-ml/ppx_core:=
+ dev-ml/ppx_tools:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/typerep:=
+ "
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}