summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-04-27 18:03:44 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-04-27 18:06:39 +0800
commit0d784579f7d2fa66ab44c80e2ff0fba353f08dbf (patch)
treeb1d7de3e7acdbecbc8ae78c89a609aae50d893f8
parentdev-python/httpretty: Add missing test deps (diff)
downloadgentoo-0d784579f7d2fa66ab44c80e2ff0fba353f08dbf.tar.gz
gentoo-0d784579f7d2fa66ab44c80e2ff0fba353f08dbf.tar.bz2
gentoo-0d784579f7d2fa66ab44c80e2ff0fba353f08dbf.zip
dev-python/numpy: fix regressions introduced by 48dd16c7839fd.
Bug: https://github.com/gentoo/gentoo/pull/15315 Closes: https://bugs.gentoo.org/660754 Package-Manager: Portage-2.3.88, Repoman-2.3.18 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--dev-python/numpy/numpy-1.18.3.ebuild17
-rw-r--r--profiles/arch/powerpc/package.use.mask4
-rw-r--r--profiles/arch/sparc/package.use.mask4
3 files changed, 13 insertions, 12 deletions
diff --git a/dev-python/numpy/numpy-1.18.3.ebuild b/dev-python/numpy/numpy-1.18.3.ebuild
index 274e9fd371f2..05e59611dcc7 100644
--- a/dev-python/numpy/numpy-1.18.3.ebuild
+++ b/dev-python/numpy/numpy-1.18.3.ebuild
@@ -10,7 +10,7 @@ FORTRAN_NEEDED=lapack
DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit autotools distutils-r1 flag-o-matic fortran-2 multiprocessing toolchain-funcs
+inherit distutils-r1 flag-o-matic fortran-2 multiprocessing toolchain-funcs
DOC_PV="1.16.4"
DESCRIPTION="Fast array and numerical python library"
@@ -24,7 +24,7 @@ SRC_URI="
)"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="doc lapack"
RDEPEND="
@@ -37,11 +37,7 @@ BDEPEND="
${RDEPEND}
app-arch/unzip
>=dev-python/cython-0.29.15[${PYTHON_USEDEP}]
- lapack? (
- >=sys-devel/automake-1.16.2
- >=sys-devel/gcc-6.5.0-r1[fortran]
- virtual/pkgconfig
- )
+ lapack? ( virtual/pkgconfig )
test? (
>=dev-python/hypothesis-5.8.0[${PYTHON_USEDEP}]
>=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
@@ -62,11 +58,6 @@ src_unpack() {
fi
}
-src_prepare() {
- default
- eautomake
-}
-
python_prepare_all() {
if use lapack; then
local incdir="${EPREFIX}"/usr/include
@@ -118,6 +109,8 @@ python_prepare_all() {
}
python_compile() {
+ export MAKEOPTS=-j1 #660754
+
distutils-r1_python_compile ${NUMPY_FCONFIG}
}
diff --git a/profiles/arch/powerpc/package.use.mask b/profiles/arch/powerpc/package.use.mask
index 8baff9448146..9219f7cf2a43 100644
--- a/profiles/arch/powerpc/package.use.mask
+++ b/profiles/arch/powerpc/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Benda Xu <heroxbd@gentoo.org> (2020-04-27)
+# tests optionally depend on dev-python/hypothesis
+dev-python/numpy test
+
# Lars Wendler <polynomial-c@gentoo.org> (2020-04-20)
# Not keyworded on ppc
net-misc/whois xcrypt
diff --git a/profiles/arch/sparc/package.use.mask b/profiles/arch/sparc/package.use.mask
index 5eed363d11a2..5be369d76faf 100644
--- a/profiles/arch/sparc/package.use.mask
+++ b/profiles/arch/sparc/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Benda Xu <heroxbd@gentoo.org> (2020-04-27)
+# tests optionally depend on dev-python/hypothesis
+dev-python/numpy test
+
# Rolf Eike Beer <eike@sf-mail.de> (2020-04-26)
# tests optionally depend on dev-ruby/coffee-script needing nodejs
dev-ruby/tilt test