summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:12:56 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:15 +0000
commit0dcdfca53069d6f7858fadc0dda1aadc4a9caa25 (patch)
tree974816ab2f98dd7b1135151e7ed326a0b266adb4
parentmate-extra/caja-dropbox: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-0dcdfca53069d6f7858fadc0dda1aadc4a9caa25.tar.gz
gentoo-0dcdfca53069d6f7858fadc0dda1aadc4a9caa25.tar.bz2
gentoo-0dcdfca53069d6f7858fadc0dda1aadc4a9caa25.zip
media-gfx/dcraw: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/dcraw/dcraw-9.28.0-r2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/media-gfx/dcraw/dcraw-9.28.0-r2.ebuild b/media-gfx/dcraw/dcraw-9.28.0-r2.ebuild
index 49a9c411cf33..607282673bfd 100644
--- a/media-gfx/dcraw/dcraw-9.28.0-r2.ebuild
+++ b/media-gfx/dcraw/dcraw-9.28.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -74,8 +74,8 @@ src_compile() {
# rawphoto gimp plugin
if use gimp; then
run_build $(tc-getCC) ${CFLAGS} ${LDFLAGS} \
- $(pkg-config --cflags gimpui-2.0) rawphoto.c -o rawphoto \
- $(pkg-config --libs gimpui-2.0)
+ $($(tc-getPKG_CONFIG) --cflags gimpui-2.0) rawphoto.c -o rawphoto \
+ $($(tc-getPKG_CONFIG) --libs gimpui-2.0)
fi
if use nls; then
@@ -92,7 +92,7 @@ src_install() {
# rawphoto gimp plugin
if use gimp; then
- insinto "$(pkg-config --variable=gimplibdir gimp-2.0)/plug-ins"
+ insinto "$($(tc-getPKG_CONFIG) --variable=gimplibdir gimp-2.0)/plug-ins"
insopts -m0755
doins rawphoto
fi