summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:08:29 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:50 +0100
commit0e7e154aec9f904e3c15ff6f5749294f8764a789 (patch)
tree77a43ade1d8a3e23fc04631a7ecdaf3af0d9de11
parentdev-haskell/libmpd: add 0.10.0.0 (diff)
downloadgentoo-0e7e154aec9f904e3c15ff6f5749294f8764a789.tar.gz
gentoo-0e7e154aec9f904e3c15ff6f5749294f8764a789.tar.bz2
gentoo-0e7e154aec9f904e3c15ff6f5749294f8764a789.zip
dev-haskell/libyaml: Invert logic of USE=no-unicode
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/libyaml/libyaml-0.1.2.ebuild7
-rw-r--r--dev-haskell/libyaml/metadata.xml2
2 files changed, 6 insertions, 3 deletions
diff --git a/dev-haskell/libyaml/libyaml-0.1.2.ebuild b/dev-haskell/libyaml/libyaml-0.1.2.ebuild
index 6bcbb87f5f82..3dfe12bbb09c 100644
--- a/dev-haskell/libyaml/libyaml-0.1.2.ebuild
+++ b/dev-haskell/libyaml/libyaml-0.1.2.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-IUSE="no-unicode system-libyaml"
+IUSE="+unicode system-libyaml"
RDEPEND=">=dev-haskell/conduit-1.2.8:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
>=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
@@ -27,7 +27,10 @@ DEPEND="${RDEPEND}
"
src_configure() {
+ local unicode_flag="no-unicode"
+ use unicode && unicode_flag="-no-unicode"
+
haskell-cabal_src_configure \
- $(cabal_flag no-unicode no-unicode) \
+ --flag="${unicode_flag}" \
$(cabal_flag system-libyaml system-libyaml)
}
diff --git a/dev-haskell/libyaml/metadata.xml b/dev-haskell/libyaml/metadata.xml
index 97319385e94a..dd6483d64c56 100644
--- a/dev-haskell/libyaml/metadata.xml
+++ b/dev-haskell/libyaml/metadata.xml
@@ -6,7 +6,7 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name="no-unicode">Don't enable unicode output. Instead, unicode characters will be escaped.</flag>
+ <flag name="unicode">Enable unicode output. Otherwise, unicode characters will be escaped.</flag>
<flag name="system-libyaml">Use the system-wide libyaml instead of the bundled copy</flag>
</use>
</pkgmetadata>