summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-16 07:56:27 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-16 09:17:37 +0100
commit0ec0e0f3404bc7f339f342b136e06ba92d4f02a9 (patch)
tree40e1042d26b66efb911b51a4101939675e933068
parentdev-python/nbformat: Bump to 5.10.3 (diff)
downloadgentoo-0ec0e0f3404bc7f339f342b136e06ba92d4f02a9.tar.gz
gentoo-0ec0e0f3404bc7f339f342b136e06ba92d4f02a9.tar.bz2
gentoo-0ec0e0f3404bc7f339f342b136e06ba92d4f02a9.zip
dev-python/dask: Bump to 2024.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2024.3.1.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 38033fcec0ee..f5505288027c 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,3 +1,4 @@
DIST dask-2024.2.0.gh.tar.gz 9335533 BLAKE2B c23bf3da4624b187f30cf0ca5fe885a705e8e4be9b9d919ff491399d1029d43c4343159acf9bd6a61611af7ecacd8c00bd1cb199176b742ad3c556e2a5da65c9 SHA512 8a0b5c17aa34b309aed370852ddfb25cde220de87fe9c1afd8d88f7a4abad9f4523c90424f8a5cc1d7186850f35071ee10e7a33396ca2c4c4be975783cc5fe2e
DIST dask-2024.2.1.gh.tar.gz 9341330 BLAKE2B f5d02fd7389711c5d7b048e541c28af87a8425931277ce035163c16699d7275b802afc90c71256ac268f67390afc9dd4a393df2ddeedac6e378bf787edf43e41 SHA512 3863ec9126ba9fa0cf067a62d3d763d7cf52c6e49cdbfc258336b4536922c46f23443ff8aa4eb49176a38d2a70e03e2d5ca8a2c4b96c98d474654eec4e44c9c5
DIST dask-2024.3.0.gh.tar.gz 9342813 BLAKE2B d71d3ed2531517a1d01ab72862484b86a1080ecff056c11041ab723e67369794ca3c1f486cd18019f38e49deda65f25acb566e4431c6a1121ddfb930669b20b1 SHA512 be56244c7a96cf43062e7e3658befb73bf318729a2bb906d78ee8ba91a1f4fcfab22e6b01c00cda9bfb8de3f74adf8fc1a5dfb6681e51deb00ba5011dd1dc325
+DIST dask-2024.3.1.gh.tar.gz 9342821 BLAKE2B 2d85be59caa48005b1951d56c4af5991bc378932cac34fc9fcfdd4a55027cacf60738af11eab87d13f764b90d7cba74ba239e10949a8231d0e08d4e5a2eaf936 SHA512 465a489cdfd59eb7b20a4736549a0cee9bedb5b864339b1040c5490c70a4a7486a83bdf4d951a1ea15529685838dcdc4d2554b03ebd9b8227cce0d270e80a7cd
diff --git a/dev-python/dask/dask-2024.3.1.ebuild b/dev-python/dask/dask-2024.3.1.ebuild
new file mode 100644
index 000000000000..ab481660322a
--- /dev/null
+++ b/dev-python/dask/dask-2024.3.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="
+ https://www.dask.org/
+ https://github.com/dask/dask/
+ https://pypi.org/project/dask/
+"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/click-8.1[${PYTHON_USEDEP}]
+ >=dev-python/cloudpickle-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.9.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.21[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-1.2.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.10.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.13.0[${PYTHON_USEDEP}]
+ ' 3.{10..11})
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=dev-python/versioneer-0.28[${PYTHON_USEDEP}]
+ test? (
+ dev-libs/apache-arrow[parquet,snappy]
+ dev-python/dask-expr[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pyarrow[parquet,${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # fails with sqlalchemy-2.0, even though we don't use it x_x
+ sed -i -e '/RemovedIn20Warning/d' pyproject.toml || die
+ sed -i -e 's:--cov-config=pyproject.toml::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # more tests relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ dask/array/tests/test_random.py::test_RandomState_only_funcs
+ dask/dataframe/tests/test_dataframe.py::test_view
+ dask/dataframe/tests/test_shuffle.py::test_npartitions_auto_raises_deprecation_warning
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+ dask/array/tests/test_linalg.py::test_solve_assume_a
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
+ dask/array/tests/test_image.py::test_preprocess
+ dask/tests/test_system.py::test_cpu_count_cgroups_v2
+ # require sqlalchemy<2.0
+ dask/dataframe/io/tests/test_sql.py
+ # crashes
+ dask/tests/test_base.py::test_tokenize_object_with_recursion_error
+ # regression with new pandas (?)
+ dask/dataframe/tests/test_multi.py::test_concat5
+ )
+
+ if ! has_version -b "dev-python/pyarrow[parquet,${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ # fails if pyarrow is installed without USE=parquet
+ # (optional dep, skipped if it's not installed at all)
+ dask/dataframe/io/tests/test_parquet.py::test_pyarrow_filter_divisions
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_rerunfailures -m "not network" -o xfail_strict=False
+}