summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-24 14:36:46 +0000
committerSam James <sam@gentoo.org>2020-11-24 14:36:54 +0000
commit0f0f8e8ed83d82b7d781df6c20e0861b7d230b96 (patch)
treebd797ff9e37b6a3549a3139c2db7dc6b5c15bf1d
parentdev-python/lz4: bump to 3.1.1 (diff)
downloadgentoo-0f0f8e8ed83d82b7d781df6c20e0861b7d230b96.tar.gz
gentoo-0f0f8e8ed83d82b7d781df6c20e0861b7d230b96.tar.bz2
gentoo-0f0f8e8ed83d82b7d781df6c20e0861b7d230b96.zip
dev-python/fakeredis: bump to 1.4.5
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/fakeredis/Manifest1
-rw-r--r--dev-python/fakeredis/fakeredis-1.4.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index cd00262d0511..5b2c5375e03a 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,2 +1,3 @@
DIST fakeredis-1.4.3.gh.tar.gz 64936 BLAKE2B 61f85ec5c5b05b45f421a422f0cab072c24864a970097d2e15340ba7655ba9182c312091b9b6570aaf366fc241bb430fa528068db2728d42b615aecbec635d1a SHA512 56a0cc6d51025ceb24bb46dcdb2a8f638699f9928552d9b0f1592ff93903397304a9166e167de4d7c1d9f718a486f71e249c36e7c0667bde59f46710896da987
DIST fakeredis-1.4.4.gh.tar.gz 65483 BLAKE2B 500346bb96d2c1308d0565a006ca037784ff25670fd313c94df13f0ceb6d90dbec044c71c95bdabbd593823e26b47a8f8f2a2f7f5b3fa9307b9ccea407b2872c SHA512 04b85675b088e698f11edf8727b88544640cac0caa0048f009371a4c9a9ebc17443d8f03c9ead20ca40608f618c4d394cd6ba4c9d1e5e59b058713756856e450
+DIST fakeredis-1.4.5.gh.tar.gz 66197 BLAKE2B f0f36d1e209673f7722849e835c2a33fac9f7e8bfb1294ecf2e69478295f14af514d0fc4a5732a20ce099333b136d682591fef031ce90d6262fa8c9025cbfa2e SHA512 e16ae5c5947a924b0c9c40ae68efebad5cccea9f88d1b5c3f1677e1ccb8c1fa75dbafc9b413c2359b774f3043c387ff91ecd4e2e21204036883175944338d59b
diff --git a/dev-python/fakeredis/fakeredis-1.4.5.ebuild b/dev-python/fakeredis/fakeredis-1.4.5.ebuild
new file mode 100644
index 000000000000..0ca618c58661
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-1.4.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/jamesls/fakeredis/
+ https://pypi.org/project/fakeredis/"
+SRC_URI="
+ https://github.com/jamesls/fakeredis/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ # tests for use with aioredis, not packaged in ::gentoo
+ --ignore test/test_aioredis.py
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+
+ pytest -vv "${excludes[@]}" || die "Tests failed with ${EPYTHON}"
+}