summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <rahil3108@gmail.com>2023-11-17 16:05:13 +0530
committerZac Medico <zmedico@gentoo.org>2023-11-28 22:16:33 -0800
commit0fd1ca6a523342c779a7aae8a67782762a87f623 (patch)
treed4d284170caf574a84a5e4c8aa6517c1543e51d8
parentapp-containers/containers-image: add 5.29.0 & update live (diff)
downloadgentoo-0fd1ca6a523342c779a7aae8a67782762a87f623.tar.gz
gentoo-0fd1ca6a523342c779a7aae8a67782762a87f623.tar.bz2
gentoo-0fd1ca6a523342c779a7aae8a67782762a87f623.zip
app-containers/containers-storage: add 1.51.0 & update live
1. Fix dep category of go-md2man 2. remove redundant functions 3. Add EPREFIX while installing Signed-off-by: Rahil Bhimjiani <rahil3108@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33865 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-containers/containers-storage/Manifest1
-rw-r--r--app-containers/containers-storage/containers-storage-1.51.0.ebuild37
-rw-r--r--app-containers/containers-storage/containers-storage-9999.ebuild14
3 files changed, 41 insertions, 11 deletions
diff --git a/app-containers/containers-storage/Manifest b/app-containers/containers-storage/Manifest
index 59d2291922ae..5e7953f39084 100644
--- a/app-containers/containers-storage/Manifest
+++ b/app-containers/containers-storage/Manifest
@@ -1 +1,2 @@
DIST containers-storage-1.50.2.tar.gz 4278269 BLAKE2B 3a2b08c710c043cfc130b9ffe39807e5ced8aa3cdb9805e9d9a4d0f60d8136f99e78ca03992c566b7c7d9aa1c25a2ab9da5e9edc4f1f841663302f5873dce419 SHA512 eb2ca9d243511abd5d6d1727c60166422dbfef4a3ddbb5062e58d915d0705afcd10ded8f1f79e897f9f5244fb6b6d349fbf3ed86ae57f41e31a1965c4e926941
+DIST containers-storage-1.51.0.tar.gz 4283732 BLAKE2B 108401d68e617e6237e68cf2147113680e0452a8d15ee099da9872508800f3e7b8f2c5508e17d9c5f3d58fec4efc1c20f23f1a567fe592533c0e63efd05ae5c8 SHA512 89916b49438bce8bb774b4aa799676d4b3a946a0b5207a1b5241b1a3ac0875b06b3cd8e81d7e23332ceae6010b693516fc31d8c7f75a37e7ad3056a83c75b6c1
diff --git a/app-containers/containers-storage/containers-storage-1.51.0.ebuild b/app-containers/containers-storage/containers-storage-1.51.0.ebuild
new file mode 100644
index 000000000000..4af5e711a1f0
--- /dev/null
+++ b/app-containers/containers-storage/containers-storage-1.51.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Default config and docs related to Containers' storage"
+HOMEPAGE="https://github.com/containers/storage"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/storage.git"
+else
+ SRC_URI="https://github.com/containers/storage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND=">=dev-go/go-md2man-2.0.2"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/system-md2man-path.patch
+}
+
+src_compile() {
+ emake -C docs containers-storage.conf.5
+}
+
+src_install() {
+ emake DESTDIR="${ED}" -C docs install
+
+ insinto /etc/containers
+ doins storage.conf
+}
diff --git a/app-containers/containers-storage/containers-storage-9999.ebuild b/app-containers/containers-storage/containers-storage-9999.ebuild
index 523b3a92b7ba..4af5e711a1f0 100644
--- a/app-containers/containers-storage/containers-storage-9999.ebuild
+++ b/app-containers/containers-storage/containers-storage-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DESCRIPTION="Default config and docs related to Containers' storage"
HOMEPAGE="https://github.com/containers/storage"
-if [[ ${PV} == *9999* ]]; then
+if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/containers/storage.git"
else
@@ -18,27 +18,19 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-DEPEND=">=dev-go/go-md2man-2.0.2"
+BDEPEND=">=dev-go/go-md2man-2.0.2"
src_prepare() {
default
eapply "${FILESDIR}"/system-md2man-path.patch
}
-src_configure() {
- return
-}
-
src_compile() {
emake -C docs containers-storage.conf.5
}
-src_test() {
- return
-}
-
src_install() {
- emake DESTDIR="${D}" -C docs install
+ emake DESTDIR="${ED}" -C docs install
insinto /etc/containers
doins storage.conf