summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <rahil3108@gmail.com>2023-11-17 15:53:34 +0530
committerZac Medico <zmedico@gentoo.org>2023-11-28 22:16:32 -0800
commit3c6adf5ee3a73ab91a089958291f1f492b43a53f (patch)
treea570ab5858eeaec79cc5767c945196792c1f965c
parentapp-containers/containers-common: add 0.57.0 and update live (diff)
downloadgentoo-3c6adf5ee3a73ab91a089958291f1f492b43a53f.tar.gz
gentoo-3c6adf5ee3a73ab91a089958291f1f492b43a53f.tar.bz2
gentoo-3c6adf5ee3a73ab91a089958291f1f492b43a53f.zip
app-containers/containers-image: add 5.29.0 & update live
1. Fix dep category of go-md2man 2. remove redundant functions 3. Add EPREFIX while installing Signed-off-by: Rahil Bhimjiani <rahil3108@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-containers/containers-image/Manifest1
-rw-r--r--app-containers/containers-image/containers-image-5.29.0.ebuild37
-rw-r--r--app-containers/containers-image/containers-image-9999.ebuild14
3 files changed, 41 insertions, 11 deletions
diff --git a/app-containers/containers-image/Manifest b/app-containers/containers-image/Manifest
index 386995e8ccba..ac4252cf4d1f 100644
--- a/app-containers/containers-image/Manifest
+++ b/app-containers/containers-image/Manifest
@@ -1 +1,2 @@
DIST containers-image-5.28.0.tar.gz 688100 BLAKE2B 0cee8be579bd11eb0524590d8afe16b6ef863d7adfd74db51b68385142804c8096fec3f2a492e0d5a5021eba9edc91219b327138635aaa329c6ef7d0c01129c8 SHA512 0b76539e04016f5f1067c576a877ace475f25d0f0840fc969606601105a8a7f0e242cc054b0a2cfb6f1b751d850734360a524c78563fdf2330c8ae8c11bba1cf
+DIST containers-image-5.29.0.tar.gz 706774 BLAKE2B 0af5c7c43e8b75df591cbd291d0865ac19322bf62ad98b4f36cfb51b006ced088f91f0b3f582ce29ae80582e72087467cfe589683216eeb50ad3762152853dc0 SHA512 5e670f85fe0b43769667f1a3e710434ab65c4ec2d8c60b0cad4b0ed41c35f84677528f9dfecb0b946de556ebbdd56f4949760432ec49b1b3c691120a323af869
diff --git a/app-containers/containers-image/containers-image-5.29.0.ebuild b/app-containers/containers-image/containers-image-5.29.0.ebuild
new file mode 100644
index 000000000000..7e9e9b9dad81
--- /dev/null
+++ b/app-containers/containers-image/containers-image-5.29.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Default config and docs related to Containers' images"
+HOMEPAGE="https://github.com/containers/image"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/image.git"
+else
+ SRC_URI="https://github.com/containers/image/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND=">=dev-go/go-md2man-2.0.2"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/fix-warnings.patch"
+}
+
+src_compile() {
+ emake docs
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ insinto /etc/containers
+ doins registries.conf
+}
diff --git a/app-containers/containers-image/containers-image-9999.ebuild b/app-containers/containers-image/containers-image-9999.ebuild
index a29e5e602b78..7e9e9b9dad81 100644
--- a/app-containers/containers-image/containers-image-9999.ebuild
+++ b/app-containers/containers-image/containers-image-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DESCRIPTION="Default config and docs related to Containers' images"
HOMEPAGE="https://github.com/containers/image"
-if [[ ${PV} == *9999* ]]; then
+if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/containers/image.git"
else
@@ -18,27 +18,19 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-DEPEND=">=dev-go/go-md2man-2.0.2"
+BDEPEND=">=dev-go/go-md2man-2.0.2"
src_prepare() {
default
eapply "${FILESDIR}/fix-warnings.patch"
}
-src_configure() {
- return
-}
-
src_compile() {
emake docs
}
-src_test() {
- return
-}
-
src_install() {
- emake DESTDIR="${D}" install
+ emake DESTDIR="${ED}" install
insinto /etc/containers
doins registries.conf