summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-30 21:17:11 +0000
committerSam James <sam@gentoo.org>2021-03-30 21:45:41 +0000
commit11141207fdbf6b0bf8a9d355876d52f7ba829482 (patch)
tree9726cf1678915fe14b32ada74847c72aa52df2df
parentnet-mail/sendEmail: port to EAPI 7, drop base.eclass (diff)
downloadgentoo-11141207.tar.gz
gentoo-11141207.tar.bz2
gentoo-11141207.zip
net-misc/socket: port to EAPI 7, drop base.eclass
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/socket/files/socket-1.5-makefile.patch4
-rw-r--r--net-misc/socket/socket-1.5.ebuild12
2 files changed, 9 insertions, 7 deletions
diff --git a/net-misc/socket/files/socket-1.5-makefile.patch b/net-misc/socket/files/socket-1.5-makefile.patch
index 7dc3e7c1f5c3..a204791ce5b5 100644
--- a/net-misc/socket/files/socket-1.5-makefile.patch
+++ b/net-misc/socket/files/socket-1.5-makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2008-06-27 13:57:47.000000000 +0400
-+++ Makefile 2013-02-05 00:42:25.241748516 +0400
+--- a/Makefile
++++ b/Makefile
@@ -38,9 +38,8 @@
INSTALLMANPATH = $(INSTALLBASE)/man
INSTALLMANMODE = 444
diff --git a/net-misc/socket/socket-1.5.ebuild b/net-misc/socket/socket-1.5.ebuild
index a08430d13f1f..be38d567737b 100644
--- a/net-misc/socket/socket-1.5.ebuild
+++ b/net-misc/socket/socket-1.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit base toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A shell-level interface to TCP sockets"
HOMEPAGE="http://www.jnickelsen.de/socket/"
@@ -12,10 +12,11 @@ SRC_URI="http://www.jnickelsen.de/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
-
IUSE="examples"
-PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+)
src_compile() {
emake CC="$(tc-getCC)"
@@ -25,6 +26,7 @@ src_install() {
dobin socket
doman socket.1
dodoc BLURB CHANGES README
+
if use examples; then
docinto examples
dodoc scripts/*