summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:42:08 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:09:58 +0100
commit132ed49c772b4318dac4e66c8d6752a367c9e274 (patch)
tree4c52c22f2f6d96eb2f26511e9eb80f07b7cdb890
parentmedia-libs/openctm: respect ${PKG_CONFIG}, depend on pkgconfig, patch cleanup (diff)
downloadgentoo-132ed49c772b4318dac4e66c8d6752a367c9e274.tar.gz
gentoo-132ed49c772b4318dac4e66c8d6752a367c9e274.tar.bz2
gentoo-132ed49c772b4318dac4e66c8d6752a367c9e274.zip
media-plugins/ir_lv2: respect ${PKG_CONFIG}, multilib--
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-plugins/ir_lv2/files/ir_lv2-1.3.4-respect-flags.patch6
-rw-r--r--media-plugins/ir_lv2/ir_lv2-1.3.4-r1.ebuild8
2 files changed, 6 insertions, 8 deletions
diff --git a/media-plugins/ir_lv2/files/ir_lv2-1.3.4-respect-flags.patch b/media-plugins/ir_lv2/files/ir_lv2-1.3.4-respect-flags.patch
index e375969072e3..79f851c9580a 100644
--- a/media-plugins/ir_lv2/files/ir_lv2-1.3.4-respect-flags.patch
+++ b/media-plugins/ir_lv2/files/ir_lv2-1.3.4-respect-flags.patch
@@ -1,5 +1,3 @@
-diff --git a/Makefile b/Makefile
-index 031f865..4d25e97 100644
--- a/Makefile
+++ b/Makefile
@@ -20,7 +20,7 @@ CC ?= gcc
@@ -7,7 +5,7 @@ index 031f865..4d25e97 100644
# change "-O2 -ffast-math" to "-g -O0" below if you want to debug the plugin
-CPPFLAGS += -Wall -I. -I/usr/include `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gthread-2.0` -D__STDC_FORMAT_MACROS -O2 -ffast-math
-+CPPFLAGS += -Wall -I. -I/usr/include `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gthread-2.0` -D__STDC_FORMAT_MACROS -ffast-math
++CPPFLAGS += -Wall -I. -I/usr/include `pkg-config --cflags gtk+-2.0` `${PKG_CONFIG} --cflags gthread-2.0` -D__STDC_FORMAT_MACROS -ffast-math
LIBS += -lc -lm -lzita-convolver -lsamplerate -lsndfile `pkg-config --libs gthread-2.0` `pkg-config --libs gtk+-2.0`
ifeq ($(shell pkg-config --atleast-version='2.16' gtk+-2.0; echo $$?), 1)
@@ -16,7 +14,7 @@ index 031f865..4d25e97 100644
endif
-C4CFLAGS = -Wall -I. -I/usr/include `pkg-config --cflags gthread-2.0` -O2 -ffast-math
-+C4CFLAGS = -Wall -I. -I/usr/include `pkg-config --cflags gthread-2.0` -ffast-math
++C4CFLAGS = -Wall -I. -I/usr/include `${PKG_CONFIG} --cflags gthread-2.0` -ffast-math
C4LIBS = -lsndfile `pkg-config --libs gthread-2.0`
all: ir.so ir_gui.so
diff --git a/media-plugins/ir_lv2/ir_lv2-1.3.4-r1.ebuild b/media-plugins/ir_lv2/ir_lv2-1.3.4-r1.ebuild
index 232d3932b3de..ede744418cca 100644
--- a/media-plugins/ir_lv2/ir_lv2-1.3.4-r1.ebuild
+++ b/media-plugins/ir_lv2/ir_lv2-1.3.4-r1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs flag-o-matic multilib
+inherit toolchain-funcs flag-o-matic
DESCRIPTION="LV2 convolver plugin especially for creating reverb effects"
HOMEPAGE="https://tomszilagyi.github.io/plugins/ir.lv2/"
SRC_URI="https://github.com/tomszilagyi/ir.lv2/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S=${WORKDIR}/${PN/_/.}-${PV}
+S="${WORKDIR}"/${PN/_/.}-${PV}
LICENSE="GPL-2+"
SLOT="0"
@@ -31,7 +31,7 @@ PATCHES=(
DOCS=( README.md sshot.png ChangeLog )
src_compile() {
- tc-export CC CXX
+ tc-export CC CXX PKG_CONFIG
emake
use tools && emake convert4chan
}