summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-28 05:37:42 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-28 06:55:28 +0100
commit180fde768e628d6f368d8aa99a8ea9d080a50045 (patch)
treeeb2c3fe037eedabf8b03a06f99858db9d5391ef6
parentdev-python/boto3: Bump to 1.34.72 (diff)
downloadgentoo-180fde768e628d6f368d8aa99a8ea9d080a50045.tar.gz
gentoo-180fde768e628d6f368d8aa99a8ea9d080a50045.tar.bz2
gentoo-180fde768e628d6f368d8aa99a8ea9d080a50045.zip
app-admin/awscli: Bump to 1.32.72
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.72.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index e1cbcf6a8f29..fcfe7a9a48be 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.32.64.gh.tar.gz 2672156 BLAKE2B 6707984b03e004ed8672b35694c9e4be7
DIST aws-cli-1.32.69.gh.tar.gz 2675479 BLAKE2B 7a8ec84c029662145aaf49afd1b9194a7a021249ee7bff2f5c5b704703e54ee6f09c94cd0ccf85a968187f3e8e6c85a18fa31592f6bc82dc5c2aac9aaa02a643 SHA512 09f5929fcec0ec263f80b377ee21d256c52547f9f71b8a38382b0a9d39371646d0afcc3650079147f0dc8f6fa11d33cb4a9f3977c023be37851fca761ef6ac56
DIST aws-cli-1.32.70.gh.tar.gz 2675950 BLAKE2B bbe8b0a7c2c603e977f19922bd26fc9919eec81763e9a010000e009c23914b386e5783fd0b682449f3936dcf39851da568e0c5723c7ec412de6dee8549cdf79e SHA512 ba2ec0d98b29adcb43d0a8b482af0bc6df3dd20768616ac2f4b63ef2d2a62a480e2a00ba200c1d518db13f3d98a5d14d3de04e9682627dd4fe71a78cd2c0278a
DIST aws-cli-1.32.71.gh.tar.gz 2676392 BLAKE2B d20c5ac461e1fa9547b381f1f9040943a59c4fd9bf53dfcf4359c0f5c3bb08d28304f7da057e3196a927882768a333b37a1729d6fb604a8dd07361bedf93b1e0 SHA512 a197ef31df0ef3c6b229645a5e13ba83e8dd92f89a25388615c82fe63667e1bc86936e9f0591ea709200b6218720b3510b262b46df4b61bc2210aefe46928cb9
+DIST aws-cli-1.32.72.gh.tar.gz 2676512 BLAKE2B 1ee9efca27bcd975dc641183a6d2dbb0519fa5c84608eb3918a3ccee864794c0d5bf237f905ed89e52c4a2079d484ba1c4f414af8088170c0b69efd3941a73a6 SHA512 a2a0bcdfb45971d96706a4adaeb642a09dcba33c4c261b6f445475a266c6667bdcaaf91c6acb4a9d2a038b8551ef9f59e009bdb78eab8ce3cc661dccbf2f399b
diff --git a/app-admin/awscli/awscli-1.32.72.ebuild b/app-admin/awscli/awscli-1.32.72.ebuild
new file mode 100644
index 000000000000..4a677affdbc4
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.72.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}