summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-11-25 20:18:11 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-11-25 20:18:11 +0200
commit1a3b720db94c5b4f9ac0c892e497d9376d357e7b (patch)
tree8b7753f422257724ddca27720f830b1c3bdf4ae2
parentdev-python/idna: add 3.6 (diff)
downloadgentoo-1a3b720db94c5b4f9ac0c892e497d9376d357e7b.tar.gz
gentoo-1a3b720db94c5b4f9ac0c892e497d9376d357e7b.tar.bz2
gentoo-1a3b720db94c5b4f9ac0c892e497d9376d357e7b.zip
dev-python/pymdown-extensions: add 10.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pymdown-extensions/Manifest1
-rw-r--r--dev-python/pymdown-extensions/pymdown-extensions-10.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pymdown-extensions/Manifest b/dev-python/pymdown-extensions/Manifest
index 05be9d7bb56e..255d4bb1fb98 100644
--- a/dev-python/pymdown-extensions/Manifest
+++ b/dev-python/pymdown-extensions/Manifest
@@ -1 +1,2 @@
DIST pymdown_extensions-10.4.tar.gz 785151 BLAKE2B 90d49b16e3656262eb7a591e9cd53ebd1350aab8ed8522711c595169db078924d67e23a71c63001089744166f9ee2039622bd1b847facad64503a27a6b783104 SHA512 efcd958fce5d0445ecb9c7a844caa8306998647376cdb8c04d3bfcbff45f12f949230048a0fb9be50c59e814a445e38c1e57f749c5fe7f64f82f36853ef77cf0
+DIST pymdown_extensions-10.5.tar.gz 788318 BLAKE2B cf6834a848a0276d636b75df33c3ec0bcc0988a02b2d9d7d2086a0104a3f105e080fa2acaab36c010f997f351c89c61adb165152ee3b0467ee8a41da71603abf SHA512 f574fe45a8b8b30ad51e1f6b1a1ce60a65a10e560f9f5c6db6a487309acf2d65e28d79c7edad4f58192ddbda9546fd50e279e08efcbc1c2eb707de0a84696225
diff --git a/dev-python/pymdown-extensions/pymdown-extensions-10.5.ebuild b/dev-python/pymdown-extensions/pymdown-extensions-10.5.ebuild
new file mode 100644
index 000000000000..6a8fb32958ef
--- /dev/null
+++ b/dev-python/pymdown-extensions/pymdown-extensions-10.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Extensions for Python Markdown"
+HOMEPAGE="
+ https://github.com/facelessuser/pymdown-extensions/
+ https://pypi.org/project/pymdown-extensions/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/markdown-3.5[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pygments-2.12.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest