summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-03 07:46:12 +0100
committerSam James <sam@gentoo.org>2023-04-03 07:46:50 +0100
commit1b41b2e0a7c6568538039f4e5ffb000837659dc5 (patch)
tree742bbc00bee59d40a43c30a2ae9938aca656f2ff
parentapp-misc/tmate: restore -r1 (diff)
downloadgentoo-1b41b2e0a7c6568538039f4e5ffb000837659dc5.tar.gz
gentoo-1b41b2e0a7c6568538039f4e5ffb000837659dc5.tar.bz2
gentoo-1b41b2e0a7c6568538039f4e5ffb000837659dc5.zip
app-misc/tmate: fix msgpack-c patch for older versions
Closes: https://bugs.gentoo.org/903718 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch40
-rw-r--r--app-misc/tmate/tmate-2.4.0-r2.ebuild2
2 files changed, 19 insertions, 23 deletions
diff --git a/app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch b/app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch
index 85252867a692..6fbda6197eef 100644
--- a/app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch
+++ b/app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch
@@ -1,30 +1,26 @@
https://bugs.gentoo.org/903657
https://github.com/tmate-io/tmate/pull/281
-
-From a5c6e80d3c54cd7faed52de5283b4f96bea86c13 Mon Sep 17 00:00:00 2001
-From: Carlo Cabrera <30379873+carlocab@users.noreply.github.com>
-Date: Sun, 5 Mar 2023 20:58:13 +0800
-Subject: [PATCH] Fix finding msgpack 6+
-
-`msgpack.pc` was renamed to `msgpack-c.pc` upstream in msgpack/msgpack-c#1053.
--- a/configure.ac
+++ b/configure.ac
-@@ -209,6 +209,17 @@ PKG_CHECK_MODULES(
+@@ -207,7 +207,20 @@ PKG_CHECK_MODULES(
+ LIBS="$MSGPACK_LIBS $LIBS"
+ found_msgpack=yes
],
- found_msgpack=no
- )
-+# msgpack.pc was renamed to msgpack-c.pc in 6.0.0.
-+PKG_CHECK_MODULES(
-+ MSGPACKC,
-+ msgpack-c >= 1.1.0,
+- found_msgpack=no
+ [
-+ CPPFLAGS="$MSGPACKC_CFLAGS $CPPFLAGS"
-+ LIBS="$MSGPACKC_LIBS $LIBS"
-+ found_msgpack=yes
-+ ],
-+ found_msgpack=no
-+)
++ found_msgpack=no
++ # msgpack.pc was renamed to msgpack-c.pc in 6.0.0.
++ PKG_CHECK_MODULES(
++ MSGPACKC,
++ msgpack-c >= 1.1.0,
++ [
++ CPPFLAGS="$MSGPACKC_CFLAGS $CPPFLAGS"
++ LIBS="$MSGPACKC_LIBS $LIBS"
++ found_msgpack=yes
++ ],
++ found_msgpack=no
++ )
++ ]
+ )
if test "x$found_msgpack" = xno; then
AC_MSG_ERROR("msgpack >= 1.1.0 not found")
- fi
-
diff --git a/app-misc/tmate/tmate-2.4.0-r2.ebuild b/app-misc/tmate/tmate-2.4.0-r2.ebuild
index a59788a5ce64..2c24d7966261 100644
--- a/app-misc/tmate/tmate-2.4.0-r2.ebuild
+++ b/app-misc/tmate/tmate-2.4.0-r2.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/tmate-io/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="ISC"
SLOT="0"
-KEYWORDS="amd64 ~riscv ~x86"
+KEYWORDS="~amd64 ~riscv ~x86"
IUSE="debug"
RDEPEND="