summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-06 21:48:02 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-06 22:26:35 +0100
commit1be892e848feb9c23c9b1b99dbf6883d51075636 (patch)
treead70795b18dddc748f7f368c28ed187e50b1600a
parentsci-biology/maq: Fix overlong DESCRIPTION (diff)
downloadgentoo-1be892e848feb9c23c9b1b99dbf6883d51075636.tar.gz
gentoo-1be892e848feb9c23c9b1b99dbf6883d51075636.tar.bz2
gentoo-1be892e848feb9c23c9b1b99dbf6883d51075636.zip
sci-biology/maq: Modernise to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3856
-rw-r--r--sci-biology/maq/files/maq-0.7.1-remove-64bit-flag.patch19
-rw-r--r--sci-biology/maq/maq-0.7.1-r2.ebuild43
2 files changed, 62 insertions, 0 deletions
diff --git a/sci-biology/maq/files/maq-0.7.1-remove-64bit-flag.patch b/sci-biology/maq/files/maq-0.7.1-remove-64bit-flag.patch
new file mode 100644
index 000000000000..3bcbc2b5fd51
--- /dev/null
+++ b/sci-biology/maq/files/maq-0.7.1-remove-64bit-flag.patch
@@ -0,0 +1,19 @@
+Do not hardcode -m64 into the build system
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -21,12 +21,12 @@
+ [ext_CFLAGS="-arch x86_64 -arch i386 -arch ppc64 -arch ppc"],
+ [ext_CFLAGS="-arch i386 -arch ppc"]);;
+ 0) CFLAGS="-m64"
+- AC_COMPILE_IFELSE([AC_LANG_PROGRAM], [ext_CFLAGS="-m64"], []);;
++ AC_COMPILE_IFELSE([AC_LANG_PROGRAM], [ext_CFLAGS=""], []);;
+ esac;;
+ *)
+ AC_MSG_CHECKING([if gcc accepts -m64])
+ CFLAGS="-m64"
+- AC_COMPILE_IFELSE([AC_LANG_PROGRAM], [ext_CFLAGS="-m64"; AC_MSG_RESULT([yes])],
++ AC_COMPILE_IFELSE([AC_LANG_PROGRAM], [ext_CFLAGS=""; AC_MSG_RESULT([yes])],
+ [ext_CFLAGS="-D_FILE_OFFSET_BITS=64"; AC_MSG_RESULT([no])]);;
+ esac
+ AC_ARG_ENABLE(experimental, [ --enable-experimental enable experimental features],
diff --git a/sci-biology/maq/maq-0.7.1-r2.ebuild b/sci-biology/maq/maq-0.7.1-r2.ebuild
new file mode 100644
index 000000000000..fb0140047ae4
--- /dev/null
+++ b/sci-biology/maq/maq-0.7.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Mapping and Assembly with Qualities, mapping NGS reads to reference genomes"
+HOMEPAGE="http://maq.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://sourceforge/${PN}/calib-36.dat.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-bfr-overfl.patch
+ "${FILESDIR}"/${P}-gcc-4.7.patch
+ "${FILESDIR}"/${P}-remove-64bit-flag.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/${PN}
+ doins "${WORKDIR}"/*.dat
+
+ doman maq.1
+ dodoc ${PN}.pdf
+}