summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2016-01-26 17:08:12 +0800
committerIan Delaney <idella4@gentoo.org>2016-01-26 17:09:56 +0800
commit1f0e7b02817ec265ce9a6ebc182775135140501e (patch)
treea3285f7f7cdc412f156e4cd50ab25872c583e5d7
parentmedia-libs/libsndfile: Drop version vulnerable for CVE-2015-7805 (diff)
parentdev-python/tempita: add Python 3.5 support (diff)
downloadgentoo-1f0e7b02817ec265ce9a6ebc182775135140501e.tar.gz
gentoo-1f0e7b02817ec265ce9a6ebc182775135140501e.tar.bz2
gentoo-1f0e7b02817ec265ce9a6ebc182775135140501e.zip
Merge remote-tracking branch 'remotes/sbraz/tempita'
Pull request: https://github.com/gentoo/gentoo/pull/722 l be ignored, and an empty message aborts
-rw-r--r--dev-python/tempita/tempita-0.5.3-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/tempita/tempita-0.5.3-r1.ebuild b/dev-python/tempita/tempita-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..05aad78eebda
--- /dev/null
+++ b/dev-python/tempita/tempita-0.5.3-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+MY_PN="Tempita"
+MY_P="${MY_PN}-${PV}dev"
+
+DESCRIPTION="A very small text templating language"
+HOMEPAGE="http://pythonpaste.org/tempita https://pypi.python.org/pypi/Tempita"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}dev"
+# Source for tests incomplete