summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-03-02 18:27:32 +0100
committerAlexis Ballier <aballier@gentoo.org>2022-03-02 18:45:01 +0100
commit218f0e9d77cc20c2c6f37cbe2d25e608ba80ea09 (patch)
tree48e0d97c141d5def564df7d59bdfc8b97c591e91
parentapp-emulation/libvirt: version bump to 8.1.0 (diff)
downloadgentoo-218f0e9d.tar.gz
gentoo-218f0e9d.tar.bz2
gentoo-218f0e9d.zip
sci-electronics/gazebo: fix build with ffmpeg4
Closes: https://bugs.gentoo.org/833868 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--sci-electronics/gazebo/files/ffmpeg4.patch16
-rw-r--r--sci-electronics/gazebo/gazebo-11.10.1.ebuild1
2 files changed, 17 insertions, 0 deletions
diff --git a/sci-electronics/gazebo/files/ffmpeg4.patch b/sci-electronics/gazebo/files/ffmpeg4.patch
new file mode 100644
index 000000000000..7b7c8d7270fd
--- /dev/null
+++ b/sci-electronics/gazebo/files/ffmpeg4.patch
@@ -0,0 +1,16 @@
+Index: gazebo-11.10.1/gazebo/common/VideoEncoder.cc
+===================================================================
+--- gazebo-11.10.1.orig/gazebo/common/VideoEncoder.cc
++++ gazebo-11.10.1/gazebo/common/VideoEncoder.cc
+@@ -224,7 +224,10 @@ bool VideoEncoder::Start(const std::stri
+
+ // The remainder of this function handles FFMPEG initialization of a video
+ // stream
+- const AVOutputFormat *outputFormat = nullptr;
++#if LIBAVFORMAT_VERSION_MAJOR >= 59
++ const
++#endif
++ AVOutputFormat *outputFormat = nullptr;
+
+ // This 'if' and 'free' are just for safety. We chech the value of formatCtx
+ // below.
diff --git a/sci-electronics/gazebo/gazebo-11.10.1.ebuild b/sci-electronics/gazebo/gazebo-11.10.1.ebuild
index 4641556896a7..3291c74fa777 100644
--- a/sci-electronics/gazebo/gazebo-11.10.1.ebuild
+++ b/sci-electronics/gazebo/gazebo-11.10.1.ebuild
@@ -66,6 +66,7 @@ PATCHES=(
"${FILESDIR}/qwt.patch"
"${FILESDIR}/cmake.patch"
"${FILESDIR}/ffmpeg5.patch"
+ "${FILESDIR}/ffmpeg4.patch"
)
src_configure() {