summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-17 01:00:57 +0000
committerSam James <sam@gentoo.org>2020-10-17 01:01:33 +0000
commit236ecc6da4bf3ffe0986bd2f2014e61225a2c095 (patch)
tree7805760dc9008d63fb8a47d23ac3e46b8165fa2d
parentdev-ml/camomile: bump to 1.0.2 (fix >=4.10.0 compat) (diff)
downloadgentoo-236ecc6da4bf3ffe0986bd2f2014e61225a2c095.tar.gz
gentoo-236ecc6da4bf3ffe0986bd2f2014e61225a2c095.tar.bz2
gentoo-236ecc6da4bf3ffe0986bd2f2014e61225a2c095.zip
dev-ml/ocaml-gettext: bump to 0.4.2 (fix >=4.10.0 compat)
Bug: https://bugs.gentoo.org/749149 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ml/ocaml-gettext/Manifest1
-rw-r--r--dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocaml-gettext/Manifest b/dev-ml/ocaml-gettext/Manifest
index 15b1d31599b0..06d8db2e2339 100644
--- a/dev-ml/ocaml-gettext/Manifest
+++ b/dev-ml/ocaml-gettext/Manifest
@@ -1,2 +1,3 @@
DIST ocaml-gettext-0.3.5.tar.gz 165238 BLAKE2B 3da80a80cf3e722dc2a765e005bff0e7613967a5810d13c9d3c0a5b70a919b092627d398dc777775dd2b51dfc7bbe12040b844c609027b4c60cb5d23eda47198 SHA512 a60d51c09dad3076415ef24a9bb3121f84ad649d7a9fa1b9a7da719dd385e4ed7cd9ffbabefbade7ea0daf7b0a5a5eb71b1d0ed21b369914b49f66d0d918c446
DIST ocaml-gettext-0.3.7.tar.gz 134316 BLAKE2B 9de6ef9e04afbb6001ddc5ef145a687ad88a20eef1c27d3a3e6136f81ad46100cc6496cb66e3edfbf0f7eacfa8abbccb44d846d2f676862c96b8ceb860d8f424 SHA512 1358320359b9d2f3fd97a47d69b2a619942a65605c1e5cbf25e33ef42a10273167b526bca15e6c9523b87d8ea9dfd3215334050ad8eb84a8c41d4feef880a27a
+DIST ocaml-gettext-0.4.2.tar.gz 110249 BLAKE2B 54a25ba9f8fb20194fdfaf651586222fab68f927ebfa711812f7c9a387ff40c19e1bf3f63124127356b32b0ca0be2c5ff4e1cdfaf5f3afe690b90c0ca96c470d SHA512 fb89be8d8d9e0ed9327b81a0c81c884ff3f1a97e46b475ef8084abded5c84a256de05d5aa0f42be94f43ab438276a4506af726b6950e4161359a9616fb5832ec
diff --git a/dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild b/dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild
new file mode 100644
index 000000000000..ffcd1505d09d
--- /dev/null
+++ b/dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="gettext"
+inherit dune
+
+DESCRIPTION="Provides support for internationalization of OCaml program"
+HOMEPAGE="https://github.com/gildor478/ocaml-gettext"
+SRC_URI="https://github.com/gildor478/ocaml-gettext/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +ocamlopt"
+
+BDEPEND="dev-ml/cppo"
+RDEPEND="
+ >=dev-ml/camomile-0.8.3:=
+ >=dev-ml/ocaml-fileutils-0.4.0:=
+ sys-devel/gettext
+"
+DEPEND="
+ ${RDEPEND}
+ doc? ( app-text/docbook-xsl-stylesheets dev-libs/libxslt )
+"
+
+src_install() {
+ dune_src_install
+
+ # Hack for now until we get --mandir in dune.eclass
+ cd "${ED}/usr/man" || die
+ doman man1/* man5/*
+ rm -r "${ED}/usr/man" || die
+}