summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-28 15:28:36 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-28 17:57:49 +0100
commit2399f5fec09240887c8a8a151fafc97cb6bfff14 (patch)
treecfc016d2ac890961f62137bdde3816e66c6a3875
parentnet-misc/gallery-dl: bump to 1.26.3 (diff)
downloadgentoo-2399f5fec09240887c8a8a151fafc97cb6bfff14.tar.gz
gentoo-2399f5fec09240887c8a8a151fafc97cb6bfff14.tar.bz2
gentoo-2399f5fec09240887c8a8a151fafc97cb6bfff14.zip
app-containers/earthly: drop old 0.7.17
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.7.17.ebuild74
2 files changed, 0 insertions, 76 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index 7097b713cb9b..8d46832885ae 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -1,5 +1,3 @@
-DIST earthly-0.7.17-deps.tar.xz 152916336 BLAKE2B c54a1b6166cd55ac8417004c50c742c854a90bfd642f893d24b1a626498bbdfb02ef9e6b62ef79adac65db313b7819a000a673720a816159595c92d791d9c9d2 SHA512 df5db663b716cd8104b118cc421096b4ae1ccaf72a211a72c6a56812b8e0c8c890f4607dfa99dc3e240afca123793f6378adfb38a83c53facab5f39761e53ec1
-DIST earthly-0.7.17.tar.gz 7755932 BLAKE2B e08d380673698e085cc5eb645337a709bf0ff3429f4565d15750e6f1d8aa82dc83d1f5c7aa155da163eb6b6376f275b171b88117b9a7903b23c1d7aba60fa38e SHA512 b495c5abf90397e044da3e394d859e02280c11b16f4c32f742624f7c97a51c597d32bdcc527cf5a99d4c5b09d1a238b7a6128d57e4be7cb0858e0f361fd0c597
DIST earthly-0.7.19-deps.tar.xz 152930992 BLAKE2B 436e66036a5772a8bb2f283522f064670b8bb9d8e811bf159db7c4a883d7a3be37e3acac3b003f21b806fe48a87b0aff9ea422b730b79c73d0ffcf08aeabc9c7 SHA512 154903533b406f8a2f4c7f7f41ad94ab09efd784c79ce4d579821e0d17dd9df5f783806d901e2c7a857467e4c543985847b379e167db57a0f5ed446ce78ec256
DIST earthly-0.7.19.tar.gz 7758683 BLAKE2B e81ca5c98bf92b69dff497202d9ec202d528422c16e435a90ef4758886f0b09ffed32e2a256e961db54aefd7549ba93d0983cddbb7cb878f747dcf4702fc1442 SHA512 b57215fd6dff2bbe4b2e559bc535746abdef6ddef9f808cce9519c6bff7578fb735923733ef2e4607fbbf00b9fcbde5a1f60cbb7098bc66b12165749d9404d84
DIST earthly-0.7.20-deps.tar.xz 152928984 BLAKE2B f7a17986f79c5557fa92313d4405fbfd048462933bdf2a798065f443a9f8a9d60e47a78a51580eec3a779c77147a06314742221910ca855eb580194a9d072395 SHA512 59be72396b9241e6d59fc17628b97ea962e43d119587a2a92f84715105006f96f94c6f394703f4efaba07e04eeaa4fae223bab257d00275360b217b0c614920a
diff --git a/app-containers/earthly/earthly-0.7.17.ebuild b/app-containers/earthly/earthly-0.7.17.ebuild
deleted file mode 100644
index 036afcb56edb..000000000000
--- a/app-containers/earthly/earthly-0.7.17.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module
-
-DESCRIPTION="Build automation tool that executes in containers"
-HOMEPAGE="https://earthly.dev/
- https://github.com/earthly/earthly/"
-SRC_URI="
- https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
- https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
-"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="
- || (
- app-containers/docker
- app-containers/podman
- )
-"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-src_compile() {
- mkdir -p bin || die
-
- # Git SHA is needed at runtime by earthly to pull and bootstrap images.
- local git_sha
- if [[ ${PV} == 0.7.17 ]] ; then
- git_sha=7b7d8f4abbc7a35034fcd29cfada52d3d25fcff2
- else
- die 'Could not detect "git_sha", please update the ebuild.'
- fi
-
- local go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
- local go_ldflags="
- -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
- -X main.GitSha=${git_sha}
- -X main.Version=v${PV}
- "
- local -a go_buildargs=(
- -tags "${go_tags}"
- -ldflags "${go_ldflags}"
- -o bin
- )
- ego build "${go_buildargs[@]}" ./cmd/...
-}
-
-src_install() {
- exeinto /usr/bin
- doexe bin/earthly
- newexe bin/debugger earthly-debugger
-
- einstalldocs
-}
-
-pkg_postinst() {
- if has_version "app-containers/podman" ; then
- ewarn "Podman is supported but not recommended."
- ewarn "If issues arise, then please try running earthly with docker."
- fi
-
- if has_version "app-containers/podman[rootless]" ; then
- ewarn "Running podman in rootless mode is not supported because"
- ewarn "earthly/dind and earthly/buildkit require privileged access."
- ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
- fi
-}