summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-03-30 12:15:50 -0700
committerJoonas Niilola <juippis@gentoo.org>2024-04-29 11:45:18 +0300
commit249420c672426d92a9b94496d7918994181743f9 (patch)
treeec160b312dcf6b9d46217f1b002aab8fb8f57830
parentgames-emulation/bsnes-jg: add 1.2.0 (diff)
downloadgentoo-249420c672426d92a9b94496d7918994181743f9.tar.gz
gentoo-249420c672426d92a9b94496d7918994181743f9.tar.bz2
gentoo-249420c672426d92a9b94496d7918994181743f9.zip
games-emulation/bsnes-jg: drop 1.1.2-r1
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--games-emulation/bsnes-jg/bsnes-jg-1.1.2-r1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/games-emulation/bsnes-jg/bsnes-jg-1.1.2-r1.ebuild b/games-emulation/bsnes-jg/bsnes-jg-1.1.2-r1.ebuild
deleted file mode 100644
index 3522f14ebe50..000000000000
--- a/games-emulation/bsnes-jg/bsnes-jg-1.1.2-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-MY_PN=${PN%-*}
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Jolly Good Fork of bsnes"
-HOMEPAGE="https://gitlab.com/jgemu/bsnes"
-if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
-else
- SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
- S="${WORKDIR}/${MY_P}"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-fi
-
-LICENSE="ISC GPL-3+ LGPL-2.1+ MIT ZLIB"
-SLOT="1"
-
-PATCHES=(
- "${FILESDIR}"/${P}-endianness.patch # 891201#c9
-)
-
-DEPEND="
- media-libs/jg:1=
- media-libs/libsamplerate
-"
-RDEPEND="
- ${DEPEND}
- games-emulation/jgrf
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-src_compile() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
-}
-
-src_install() {
- emake install \
- DESTDIR="${D}" \
- PREFIX="${EPREFIX}"/usr \
- DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
- LIBDIR="${EPREFIX}/usr/$(get_libdir)"
-}