summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-10 03:13:52 +0000
committerSam James <sam@gentoo.org>2024-02-10 03:23:44 +0000
commit284e7fe37a8d18cc1f3e737a05a6d196dc7ae6c9 (patch)
tree2a77ab38ab99ba892f117629e05e667150f554a1
parentdev-python/rfc3987: only depend on dev-python/regex w/o pypy (diff)
downloadgentoo-284e7fe37a8d18cc1f3e737a05a6d196dc7ae6c9.tar.gz
gentoo-284e7fe37a8d18cc1f3e737a05a6d196dc7ae6c9.tar.bz2
gentoo-284e7fe37a8d18cc1f3e737a05a6d196dc7ae6c9.zip
dev-python/aiohttp: only depend on dev-python/regex for tests w/o pypy
Skip tests importing re_assert for pypy. Bug: https://bugs.gentoo.org/924136 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/aiohttp/aiohttp-3.9.1.ebuild12
-rw-r--r--dev-python/aiohttp/aiohttp-3.9.2.ebuild10
-rw-r--r--dev-python/aiohttp/aiohttp-3.9.3.ebuild10
3 files changed, 28 insertions, 4 deletions
diff --git a/dev-python/aiohttp/aiohttp-3.9.1.ebuild b/dev-python/aiohttp/aiohttp-3.9.1.ebuild
index 52c9a3b75738..f878b034c59f 100644
--- a/dev-python/aiohttp/aiohttp-3.9.1.ebuild
+++ b/dev-python/aiohttp/aiohttp-3.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -40,8 +40,8 @@ BDEPEND="
dev-python/pytest-forked[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
+ dev-python/re-assert[${PYTHON_USEDEP}]
dev-python/time-machine[${PYTHON_USEDEP}]
' 'python3*')
test-rust? (
@@ -107,6 +107,14 @@ python_test() {
# on PyPy3 but the test suite needs an explicit switch,
# sigh
local -x AIOHTTP_NO_EXTENSIONS=1
+
+ EPYTEST_IGNORE+=(
+ # Skip tests requiring dev-python/re-assert -> dev-python/regex
+ tests/test_streams.py
+ tests/test_urldispatch.py
+ tests/test_client_session.py
+ tests/test_web_response.py
+ )
;;
esac
diff --git a/dev-python/aiohttp/aiohttp-3.9.2.ebuild b/dev-python/aiohttp/aiohttp-3.9.2.ebuild
index 9cf851e1a006..1204601b7270 100644
--- a/dev-python/aiohttp/aiohttp-3.9.2.ebuild
+++ b/dev-python/aiohttp/aiohttp-3.9.2.ebuild
@@ -40,8 +40,8 @@ BDEPEND="
dev-python/pytest-forked[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
+ dev-python/re-assert[${PYTHON_USEDEP}]
dev-python/time-machine[${PYTHON_USEDEP}]
' 'python3*')
test-rust? (
@@ -107,6 +107,14 @@ python_test() {
# on PyPy3 but the test suite needs an explicit switch,
# sigh
local -x AIOHTTP_NO_EXTENSIONS=1
+
+ EPYTEST_IGNORE+=(
+ # Skip tests requiring dev-python/re-assert -> dev-python/regex
+ tests/test_streams.py
+ tests/test_urldispatch.py
+ tests/test_client_session.py
+ tests/test_web_response.py
+ )
;;
esac
diff --git a/dev-python/aiohttp/aiohttp-3.9.3.ebuild b/dev-python/aiohttp/aiohttp-3.9.3.ebuild
index 9cf851e1a006..1204601b7270 100644
--- a/dev-python/aiohttp/aiohttp-3.9.3.ebuild
+++ b/dev-python/aiohttp/aiohttp-3.9.3.ebuild
@@ -40,8 +40,8 @@ BDEPEND="
dev-python/pytest-forked[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
+ dev-python/re-assert[${PYTHON_USEDEP}]
dev-python/time-machine[${PYTHON_USEDEP}]
' 'python3*')
test-rust? (
@@ -107,6 +107,14 @@ python_test() {
# on PyPy3 but the test suite needs an explicit switch,
# sigh
local -x AIOHTTP_NO_EXTENSIONS=1
+
+ EPYTEST_IGNORE+=(
+ # Skip tests requiring dev-python/re-assert -> dev-python/regex
+ tests/test_streams.py
+ tests/test_urldispatch.py
+ tests/test_client_session.py
+ tests/test_web_response.py
+ )
;;
esac