summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-19 09:07:56 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-19 09:59:44 +0100
commit29a63b1db6d76838a2fa151757ac569e77930572 (patch)
tree3f1c34d798fac3fe8f22bd74a1a5c55c151db252
parentdev-python/watchdog: Bump to 1.0.2 (diff)
downloadgentoo-29a63b1db6d76838a2fa151757ac569e77930572.tar.gz
gentoo-29a63b1db6d76838a2fa151757ac569e77930572.tar.bz2
gentoo-29a63b1db6d76838a2fa151757ac569e77930572.zip
dev-python/cfn-python-lint: Bump to 0.44.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cfn-python-lint/Manifest1
-rw-r--r--dev-python/cfn-python-lint/cfn-python-lint-0.44.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/cfn-python-lint/Manifest b/dev-python/cfn-python-lint/Manifest
index b4efda6d9545..0fc2cdca1af1 100644
--- a/dev-python/cfn-python-lint/Manifest
+++ b/dev-python/cfn-python-lint/Manifest
@@ -3,3 +3,4 @@ DIST cfn-python-lint-0.41.0.tar.gz 5192401 BLAKE2B 1f4c491446b552272cb9fea46d9d0
DIST cfn-python-lint-0.42.0.tar.gz 5307120 BLAKE2B f54c4ae7fcefa6b56714a0cfdf89d9fbce20078daac0784c6169dfbe1a110da699e37b526f306ed9734504fb3387c660ccb997748579b65afe01438124361383 SHA512 ce2e6a0031e3d67953da6f5dc96f0b155f1a1144bee75a8a476490eca69fdb700c8a3d6fd89b0afa4c8d724956e5f86bc48417035d7c94f3eed00abda47f9931
DIST cfn-python-lint-0.43.0.tar.gz 5329573 BLAKE2B 94ea659e3df02fb3b269984cdf6d879d0e2719aadf3c95f15c2982606cde220493da0a7e34e16538170f96a2611e8693dbad73033bd842e91de613c8cdcb2009 SHA512 fdde4cdffd01d1e8011f44b4eaec0bfe28f2189f53bdc3054d563cf4657c5f828751d8a12e2050d8e04687fe05bf768b5db8cbd27d2ed1c5e0d8967ede70d0ae
DIST cfn-python-lint-0.44.0.tar.gz 5339555 BLAKE2B 880f03384247f4d6af1e87850b367bdc0846e00205aa943480a3028760115e36b3f6180f536a7b16b9a1aaf9f824ceaea5ab69b7adb1da3f345506c0268b55c0 SHA512 15ee6cc0cb373f7104d9c32acb06433b5669ae89997de010f1c4f382514481f1c6b87ceb387236275299e13e63aae1a5345e71ee934f2d99c1b66e566e1ef245
+DIST cfn-python-lint-0.44.1.tar.gz 5339578 BLAKE2B 7982cba9fe422a8323c6ea270bd7ff5f41800cc16ceaa39d9fc01c2929cda5cca3b19c45de50ca8338a56aad001c834e16bfbd0ab59140381b5189e28965ba38 SHA512 b7f9ad598411d89979334aa79c7b4667ede28eef82b0b546977ba10f33f57e89366d1448e8ceeb3f28a2e53b33a409c439c3faf7d10f53fc5819f6b8693e117d
diff --git a/dev-python/cfn-python-lint/cfn-python-lint-0.44.1.ebuild b/dev-python/cfn-python-lint/cfn-python-lint-0.44.1.ebuild
new file mode 100644
index 000000000000..a83123122bcb
--- /dev/null
+++ b/dev-python/cfn-python-lint/cfn-python-lint-0.44.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-python-lint"
+SRC_URI="https://github.com/aws-cloudformation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.25.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' python3_6)
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install unittest
+
+PATCHES=(
+ "${FILESDIR}/cfn-python-lint-0.30.1-tests.patch"
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ # requires git checkout
+ sed -e 's:test_update_docs:_&:' \
+ -i test/unit/module/maintenance/test_update_documentation.py || die
+ distutils-r1_src_prepare
+}