summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-07-19 10:49:16 +0100
committerMarek Szuba <marecki@gentoo.org>2021-07-19 10:56:43 +0100
commit2a70223fc9ae8009b516d802d3867d007d199409 (patch)
treeb28c18339e050b56d18de5a7fc5f4a9a05ab89a4
parentmedia-plugins/zam-plugins: make sure x11-libs/cairo has X support (diff)
downloadgentoo-2a70223fc9ae8009b516d802d3867d007d199409.tar.gz
gentoo-2a70223fc9ae8009b516d802d3867d007d199409.tar.bz2
gentoo-2a70223fc9ae8009b516d802d3867d007d199409.zip
media-plugins/zam-plugins: make USE=-opengl more thorough
It would appear that in order to fully disable UI support in DPF one must explicitly ignore results of autodetection of ALL libraries involved. Closes: https://bugs.gentoo.org/802882 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--media-plugins/zam-plugins/zam-plugins-3.14.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/media-plugins/zam-plugins/zam-plugins-3.14.ebuild b/media-plugins/zam-plugins/zam-plugins-3.14.ebuild
index 90423a2f5c28..f3d77dcc5a73 100644
--- a/media-plugins/zam-plugins/zam-plugins-3.14.ebuild
+++ b/media-plugins/zam-plugins/zam-plugins-3.14.ebuild
@@ -46,7 +46,10 @@ src_compile() {
emake PREFIX=/usr LIBDIR=$(get_libdir) VERBOSE=true \
BASE_OPTS="" SKIP_STRIPPING=true \
HAVE_ZITA_CONVOLVER=true \
+ HAVE_CAIRO=$(usex opengl true false) \
HAVE_DGL=$(usex opengl true false) \
+ HAVE_OPENGL=$(usex opengl true false) \
+ UI_TYPE=$(usex opengl "opengl" "none") \
HAVE_JACK=$(usex jack true false)
}
@@ -54,7 +57,10 @@ src_install() {
emake PREFIX=/usr LIBDIR=$(get_libdir) VERBOSE=true \
BASE_OPTS="" SKIP_STRIPPING=true \
HAVE_ZITA_CONVOLVER=true \
+ HAVE_CAIRO=$(usex opengl true false) \
HAVE_DGL=$(usex opengl true false) \
+ HAVE_OPENGL=$(usex opengl true false) \
+ UI_TYPE=$(usex opengl "opengl" "none") \
HAVE_JACK=$(usex jack true false) \
DESTDIR="${ED}" install
}