summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-11-05 09:11:42 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-11-05 09:20:21 +0200
commit2c18d6976059999d4a2489052435f941262bb485 (patch)
tree9da50de4e3b98d2285d58cc38399218b2af00468
parentapp-misc/no-more-secrets: add tagged release 0.3.3 (diff)
downloadgentoo-2c18d6976059999d4a2489052435f941262bb485.tar.gz
gentoo-2c18d6976059999d4a2489052435f941262bb485.tar.bz2
gentoo-2c18d6976059999d4a2489052435f941262bb485.zip
app-misc/no-more-secrets: update live ebuild, respect CFLAGS/LDFLAGS
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-misc/no-more-secrets/files/no-more-secrets-9999-2018-10-25-respect-ldflags.patch48
-rw-r--r--app-misc/no-more-secrets/no-more-secrets-9999.ebuild33
2 files changed, 59 insertions, 22 deletions
diff --git a/app-misc/no-more-secrets/files/no-more-secrets-9999-2018-10-25-respect-ldflags.patch b/app-misc/no-more-secrets/files/no-more-secrets-9999-2018-10-25-respect-ldflags.patch
new file mode 100644
index 000000000000..163ec6fc09b9
--- /dev/null
+++ b/app-misc/no-more-secrets/files/no-more-secrets-9999-2018-10-25-respect-ldflags.patch
@@ -0,0 +1,48 @@
+--- a/Makefile 2020-11-05 08:48:00.592582924 +0200
++++ b/Makefile 2020-11-05 09:03:53.247026258 +0200
+@@ -1,5 +1,5 @@
+ # Installation directories following GNU conventions
+-prefix ?= /usr/local
++prefix = /usr
+ exec_prefix = $(prefix)
+ bindir = $(exec_prefix)/bin
+ sbindir = $(exec_prefix)/sbin
+@@ -12,29 +12,30 @@
+ OBJ=obj
+ SRC=src
+
+-CC ?= gcc
+-CFLAGS ?= -Wextra -Wall -O2
++export CC
++export CFLAGS
++export LDFLAGS
+
+ .PHONY: all install uninstall clean
+
+ nms: $(OBJ)/input.o $(OBJ)/error.o $(OBJ)/nmscharset.o $(OBJ)/nmstermio.o $(OBJ)/nmseffect.o $(OBJ)/nms.o | $(BIN)
+- $(CC) $(CFLAGS) -o $(BIN)/$@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(BIN)/$@ $^
+
+ sneakers: $(OBJ)/nmscharset.o $(OBJ)/nmstermio.o $(OBJ)/nmseffect.o $(OBJ)/sneakers.o | $(BIN)
+- $(CC) $(CFLAGS) -o $(BIN)/$@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(BIN)/$@ $^
+
+ all: nms sneakers
+
+ all-ncurses: nms-ncurses sneakers-ncurses
+
+ nms-ncurses: $(OBJ)/input.o $(OBJ)/error.o $(OBJ)/nmscharset.o $(OBJ)/nmstermio_ncurses.o $(OBJ)/nmseffect.o $(OBJ)/nms.o | $(BIN)
+- $(CC) $(CFLAGS) -o $(BIN)/nms $^ -lncursesw
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(BIN)/nms $^ -lncursesw
+
+ sneakers-ncurses: $(OBJ)/nmscharset.o $(OBJ)/nmstermio_ncurses.o $(OBJ)/nmseffect.o $(OBJ)/sneakers.o | $(BIN)
+- $(CC) $(CFLAGS) -o $(BIN)/sneakers $^ -lncursesw
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(BIN)/sneakers $^ -lncursesw
+
+ $(OBJ)/%.o: $(SRC)/%.c | $(OBJ)
+- $(CC) $(CFLAGS) -o $@ -c $<
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ -c $<
+
+ $(BIN):
+ mkdir $(BIN)
+
diff --git a/app-misc/no-more-secrets/no-more-secrets-9999.ebuild b/app-misc/no-more-secrets/no-more-secrets-9999.ebuild
index d5955c438a05..6fcda186cfdf 100644
--- a/app-misc/no-more-secrets/no-more-secrets-9999.ebuild
+++ b/app-misc/no-more-secrets/no-more-secrets-9999.ebuild
@@ -1,40 +1,29 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
-#if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/bartobri/${PN}.git"
- SRC_URI=""
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/bartobri/no-more-secrets.git"
inherit git-r3
- KEYWORDS=""
-#else
-# SRC_URI=""
-# KEYWORDS=""
-#fi
+else
+ SRC_URI="https://github.com/bartobri/no-more-secrets/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
-DESCRIPTION="recreate decrypting text from 1992 movie 'Sneakers'"
+DESCRIPTION="Recreate decrypting text from 1992 movie 'Sneakers'"
HOMEPAGE="https://github.com/bartobri/no-more-secrets"
LICENSE="GPL-3"
SLOT=0
DEPEND="sys-libs/ncurses:0="
-
RDEPEND="${DEPEND}"
-src_prepare() {
- sed -i 's#CC =#CC ?=#' Makefile
- sed -i 's#prefix =#prefix ?=#' Makefile
- sed -i 's#CFLAGS =#CFLAGS ?=#' Makefile
-}
+PATCHES=( "${FILESDIR}"/no-more-secrets-9999-2018-10-25-respect-ldflags.patch )
src_compile() {
- CC=$(tc-getCC) CFLAGS=${CFLAGS} emake
-}
-
-src_install() {
- prefix=/usr DESTDIR="${ED}" emake install
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" emake
}