summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-31 12:11:11 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-31 12:22:25 +0100
commit2d48118eda5dfa773c5c3fec32947a82dfd47c16 (patch)
treebc533e6c455377ec82e500417e69d27c65d6c775
parentdev-python/openapi-schema-validator: Bump to 0.4.2 (diff)
downloadgentoo-2d48118e.tar.gz
gentoo-2d48118e.tar.bz2
gentoo-2d48118e.zip
dev-python/ensurepip-pip: Bump to 23.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ensurepip-pip/Manifest1
-rw-r--r--dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/ensurepip-pip/Manifest b/dev-python/ensurepip-pip/Manifest
index f3e58ec59c9f..2f3601caaf60 100644
--- a/dev-python/ensurepip-pip/Manifest
+++ b/dev-python/ensurepip-pip/Manifest
@@ -1 +1,2 @@
DIST pip-22.3.1-py3-none-any.whl 2051534 BLAKE2B b15f5eac6b3d8d12b382aabfb7fc920bea564be7f9133050d7cb0b4627a92c1de19676dced6bcb79971701898bb1606f3ea1b44349ab35527de90936c0057c71 SHA512 f09c2a48e85108514c20fdc58466b9be6a9b7f234241ccd46e23249f690bd1ec03fa5e60c9df80f4cf31a9be64d7d59b2fa786c1d7779e284fec42b04bffc257
+DIST pip-23.0-py3-none-any.whl 2056044 BLAKE2B 3b7183fe28c8f5ed64fceee3332795615218a1263d196b461a872a91676613c1c307a68702c92b6c23d9373b29e381ad6b2c8ba811a694d9dbef429be05077b8 SHA512 7bf9f3507dab29922e9f901b0584a9a84906031dc40a58537dbc001c6c49dee5a3df4ee0c21af923c7ffbafd80fbd37beea3d04e7dd607c0b2811c1df80d7be5
diff --git a/dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild b/dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild
new file mode 100644
index 000000000000..971c00d30abe
--- /dev/null
+++ b/dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN#ensurepip-}
+WHL=${MY_PN}-${PV}-py3-none-any.whl
+
+DESCRIPTION="Shared pip wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/pip/"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${MY_PN::1}/${MY_PN}/${WHL}
+"
+S=${DISTDIR}
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MIT MPL-2.0 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${WHL}"
+}