summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-15 10:23:25 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-15 10:31:02 +0100
commit305dad95b42a52fedaa6a0f0add85eb4c63ebeeb (patch)
tree1f7f3a96f673b0fab3626c12a9b97f29a5b55534
parentsys-devel/crossdev: add 20230209 (diff)
downloadgentoo-305dad95b42a52fedaa6a0f0add85eb4c63ebeeb.tar.gz
gentoo-305dad95b42a52fedaa6a0f0add85eb4c63ebeeb.tar.bz2
gentoo-305dad95b42a52fedaa6a0f0add85eb4c63ebeeb.zip
app-portage/gemato: Bump to 19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-19.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 8e74188c2c19..26495c8a9f5f 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1 +1,2 @@
DIST gemato-18.0.gh.tar.gz 85575 BLAKE2B a923c3d7731b70798d9baf7e9faf0884723bb5e15b4e24712ecd807b79e8ca7e1532f894cf6a3b675bd72419eac41f1481fcd34fb21c9989871141819b036fa2 SHA512 9491579c3d80f9b500da2a50aed173641d049293e37f11c3c06616ff49949cae16dfd274ae79dcacca4bb4c27baf30a5f3900f45fc3dfb2b9fb5da8139db63e3
+DIST gemato-19.0.gh.tar.gz 86174 BLAKE2B b13e17f3b4388df4c0b6980db8347d68f9e6cb2657cdbcb28a8466bcdebed9e986ecac2f0f88e549741eb62accd91ed48a8ee4a714a5decce68e1529174a4c90 SHA512 3a8dfc94770e4063da8f1bf42ffc4c261345af89edd223bbf64033a82c2e31cb3369b98467fdbe9bf911b76e5ef964b676b94803579525697ddc31be1b83017b
diff --git a/app-portage/gemato/gemato-19.0.ebuild b/app-portage/gemato/gemato-19.0.ebuild
new file mode 100644
index 000000000000..7e02cc9bba9d
--- /dev/null
+++ b/app-portage/gemato/gemato-19.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="
+ https://github.com/projg2/gemato/
+ https://pypi.org/project/gemato/
+"
+SRC_URI="
+ https://github.com/projg2/gemato/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg pretty-log tools"
+
+RDEPEND="
+ gpg? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ pretty-log? (
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}