summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-01-04 13:15:03 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-01-04 13:56:48 +0100
commit3215b30eb9108cd579c7e2cb9926d77b0228419c (patch)
tree88e95351e27ff9f1941dbcdc5d0094512efeec14
parentx11-plugins/wmmsg: fix compilation with gcc 5, bug #568734 (diff)
downloadgentoo-3215b30eb9108cd579c7e2cb9926d77b0228419c.tar.gz
gentoo-3215b30eb9108cd579c7e2cb9926d77b0228419c.tar.bz2
gentoo-3215b30eb9108cd579c7e2cb9926d77b0228419c.zip
x11-plugins/wmgtemp: gcc 5 support, ebuild cleanup, bug #568994
Package-Manager: portage-2.2.26
-rw-r--r--x11-plugins/wmgtemp/files/wmgeneral-list.patch129
-rw-r--r--x11-plugins/wmgtemp/files/wmgtemp-1.0-list.patch127
-rw-r--r--x11-plugins/wmgtemp/wmgtemp-1.0-r1.ebuild43
3 files changed, 299 insertions, 0 deletions
diff --git a/x11-plugins/wmgtemp/files/wmgeneral-list.patch b/x11-plugins/wmgtemp/files/wmgeneral-list.patch
new file mode 100644
index 000000000000..66d5c81cc6d3
--- /dev/null
+++ b/x11-plugins/wmgtemp/files/wmgeneral-list.patch
@@ -0,0 +1,129 @@
+diff --git a/wmgeneral/list.c b/wmgeneral/list.c
+index a63562f..0b69885 100644
+--- a/wmgeneral/list.c
++++ b/wmgeneral/list.c
+@@ -38,7 +38,7 @@ Boston, MA 02110-1301 USA. */
+
+ /* Return a cons cell produced from (head . tail) */
+
+-INLINE LinkedList*
++LinkedList*
+ list_cons(void* head, LinkedList* tail)
+ {
+ LinkedList* cell;
+@@ -51,7 +51,7 @@ list_cons(void* head, LinkedList* tail)
+
+ /* Return the length of a list, list_length(NULL) returns zero */
+
+-INLINE int
++int
+ list_length(LinkedList* list)
+ {
+ int i = 0;
+@@ -66,7 +66,7 @@ list_length(LinkedList* list)
+ /* Return the Nth element of LIST, where N count from zero. If N
+ larger than the list length, NULL is returned */
+
+-INLINE void*
++void*
+ list_nth(int index, LinkedList* list)
+ {
+ while(index-- != 0)
+@@ -81,7 +81,7 @@ list_nth(int index, LinkedList* list)
+
+ /* Remove the element at the head by replacing it by its successor */
+
+-INLINE void
++void
+ list_remove_head(LinkedList** list)
+ {
+ if (!*list) return;
+@@ -101,7 +101,7 @@ list_remove_head(LinkedList** list)
+
+ /* Remove the element with `car' set to ELEMENT */
+ /*
+-INLINE void
++void
+ list_remove_elem(LinkedList** list, void* elem)
+ {
+ while (*list)
+@@ -112,7 +112,7 @@ list_remove_elem(LinkedList** list, void* elem)
+ }
+ }*/
+
+-INLINE LinkedList *
++LinkedList *
+ list_remove_elem(LinkedList* list, void* elem)
+ {
+ LinkedList *tmp;
+@@ -132,7 +132,7 @@ list_remove_elem(LinkedList* list, void* elem)
+
+ /* Return element that has ELEM as car */
+
+-INLINE LinkedList*
++LinkedList*
+ list_find(LinkedList* list, void* elem)
+ {
+ while(list)
+@@ -146,7 +146,7 @@ list_find(LinkedList* list, void* elem)
+
+ /* Free list (backwards recursive) */
+
+-INLINE void
++void
+ list_free(LinkedList* list)
+ {
+ if(list)
+@@ -158,7 +158,7 @@ list_free(LinkedList* list)
+
+ /* Map FUNCTION over all elements in LIST */
+
+-INLINE void
++void
+ list_mapcar(LinkedList* list, void(*function)(void*))
+ {
+ while(list)
+diff --git a/wmgeneral/list.h b/wmgeneral/list.h
+index 92c3454..3d6bad5 100644
+--- a/wmgeneral/list.h
++++ b/wmgeneral/list.h
+@@ -29,31 +29,25 @@ Boston, MA 02110-1301 USA. */
+ #ifndef __LIST_H_
+ #define __LIST_H_
+
+-#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
+-# define INLINE inline
+-#else
+-# define INLINE
+-#endif
+-
+ typedef struct LinkedList {
+ void *head;
+ struct LinkedList *tail;
+ } LinkedList;
+
+-INLINE LinkedList* list_cons(void* head, LinkedList* tail);
++LinkedList* list_cons(void* head, LinkedList* tail);
+
+-INLINE int list_length(LinkedList* list);
++int list_length(LinkedList* list);
+
+-INLINE void* list_nth(int index, LinkedList* list);
++void* list_nth(int index, LinkedList* list);
+
+-INLINE void list_remove_head(LinkedList** list);
++void list_remove_head(LinkedList** list);
+
+-INLINE LinkedList *list_remove_elem(LinkedList* list, void* elem);
++LinkedList *list_remove_elem(LinkedList* list, void* elem);
+
+-INLINE void list_mapcar(LinkedList* list, void(*function)(void*));
++void list_mapcar(LinkedList* list, void(*function)(void*));
+
+-INLINE LinkedList*list_find(LinkedList* list, void* elem);
++LinkedList*list_find(LinkedList* list, void* elem);
+
+-INLINE void list_free(LinkedList* list);
++void list_free(LinkedList* list);
+
+ #endif
diff --git a/x11-plugins/wmgtemp/files/wmgtemp-1.0-list.patch b/x11-plugins/wmgtemp/files/wmgtemp-1.0-list.patch
new file mode 100644
index 000000000000..54a2eb2c2887
--- /dev/null
+++ b/x11-plugins/wmgtemp/files/wmgtemp-1.0-list.patch
@@ -0,0 +1,127 @@
+diff -Naur src/wmgeneral.orig/list.c src/wmgeneral/list.c
+--- src/wmgeneral.orig/list.c 2016-01-04 13:10:41.091981064 +0100
++++ src/wmgeneral/list.c 2016-01-04 13:10:56.428986326 +0100
+@@ -38,7 +38,7 @@
+
+ /* Return a cons cell produced from (head . tail) */
+
+-INLINE LinkedList*
++LinkedList*
+ list_cons(void* head, LinkedList* tail)
+ {
+ LinkedList* cell;
+@@ -51,7 +51,7 @@
+
+ /* Return the length of a list, list_length(NULL) returns zero */
+
+-INLINE int
++int
+ list_length(LinkedList* list)
+ {
+ int i = 0;
+@@ -66,7 +66,7 @@
+ /* Return the Nth element of LIST, where N count from zero. If N
+ larger than the list length, NULL is returned */
+
+-INLINE void*
++void*
+ list_nth(int index, LinkedList* list)
+ {
+ while(index-- != 0)
+@@ -81,7 +81,7 @@
+
+ /* Remove the element at the head by replacing it by its successor */
+
+-INLINE void
++void
+ list_remove_head(LinkedList** list)
+ {
+ if (!*list) return;
+@@ -101,7 +101,7 @@
+
+ /* Remove the element with `car' set to ELEMENT */
+ /*
+-INLINE void
++void
+ list_remove_elem(LinkedList** list, void* elem)
+ {
+ while (*list)
+@@ -112,7 +112,7 @@
+ }
+ }*/
+
+-INLINE LinkedList *
++LinkedList *
+ list_remove_elem(LinkedList* list, void* elem)
+ {
+ LinkedList *tmp;
+@@ -132,7 +132,7 @@
+
+ /* Return element that has ELEM as car */
+
+-INLINE LinkedList*
++LinkedList*
+ list_find(LinkedList* list, void* elem)
+ {
+ while(list)
+@@ -146,7 +146,7 @@
+
+ /* Free list (backwards recursive) */
+
+-INLINE void
++void
+ list_free(LinkedList* list)
+ {
+ if(list)
+@@ -158,7 +158,7 @@
+
+ /* Map FUNCTION over all elements in LIST */
+
+-INLINE void
++void
+ list_mapcar(LinkedList* list, void(*function)(void*))
+ {
+ while(list)
+diff -Naur src/wmgeneral.orig/list.h src/wmgeneral/list.h
+--- src/wmgeneral.orig/list.h 2016-01-04 13:10:41.091981064 +0100
++++ src/wmgeneral/list.h 2016-01-04 13:10:42.883981679 +0100
+@@ -29,31 +29,25 @@
+ #ifndef __LIST_H_
+ #define __LIST_H_
+
+-#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
+-# define INLINE inline
+-#else
+-# define INLINE
+-#endif
+-
+ typedef struct LinkedList {
+ void *head;
+ struct LinkedList *tail;
+ } LinkedList;
+
+-INLINE LinkedList* list_cons(void* head, LinkedList* tail);
++LinkedList* list_cons(void* head, LinkedList* tail);
+
+-INLINE int list_length(LinkedList* list);
++int list_length(LinkedList* list);
+
+-INLINE void* list_nth(int index, LinkedList* list);
++void* list_nth(int index, LinkedList* list);
+
+-INLINE void list_remove_head(LinkedList** list);
++void list_remove_head(LinkedList** list);
+
+-INLINE LinkedList *list_remove_elem(LinkedList* list, void* elem);
++LinkedList *list_remove_elem(LinkedList* list, void* elem);
+
+-INLINE void list_mapcar(LinkedList* list, void(*function)(void*));
++void list_mapcar(LinkedList* list, void(*function)(void*));
+
+-INLINE LinkedList*list_find(LinkedList* list, void* elem);
++LinkedList*list_find(LinkedList* list, void* elem);
+
+-INLINE void list_free(LinkedList* list);
++void list_free(LinkedList* list);
+
+ #endif
diff --git a/x11-plugins/wmgtemp/wmgtemp-1.0-r1.ebuild b/x11-plugins/wmgtemp/wmgtemp-1.0-r1.ebuild
new file mode 100644
index 000000000000..8974ea955454
--- /dev/null
+++ b/x11-plugins/wmgtemp/wmgtemp-1.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="CPU and SYS temperature dockapp"
+HOMEPAGE="http://www.fluxcode.net"
+SRC_URI="http://www.fluxcode.net/${P}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ =sys-apps/lm_sensors-3*
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-list.patch
+
+ sed -i -e "s:-Wall -g:\$(CFLAGS):" src/Makefile || die "sed failed."
+
+ #Honour Gentoo LDFLAGS, rationalizing Makefile - see bug #337411.
+ sed -i -e "s:LDFLAGS =:LIBS =:" src/Makefile || die "sed failed."
+ sed -i -e "s:\$(LDFLAGS) -o \$(BINARY):\$(LDFLAGS) -o \$(BINARY) \$(LIBS):" src/Makefile || die "sed failed."
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dodoc BUGS CREDITS README TODO
+ dobin src/wmgtemp
+ doman wmgtemp.1
+}