summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-30 00:52:13 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-30 00:53:24 -0800
commit3224c7450d62ca287cf0a6eec9160e0031720c07 (patch)
tree09f3795ab717f37c59a7f57249a59f0e50d36d69
parentx11-misc/tdrop: new package, dropdown window creator (diff)
downloadgentoo-3224c7450d62ca287cf0a6eec9160e0031720c07.tar.gz
gentoo-3224c7450d62ca287cf0a6eec9160e0031720c07.tar.bz2
gentoo-3224c7450d62ca287cf0a6eec9160e0031720c07.zip
x11-misc/tdrop: add live ebuild
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--x11-misc/tdrop/tdrop-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/tdrop/tdrop-9999.ebuild b/x11-misc/tdrop/tdrop-9999.ebuild
new file mode 100644
index 000000000000..1031384a291e
--- /dev/null
+++ b/x11-misc/tdrop/tdrop-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="WM-Independent Dropdown Creator"
+HOMEPAGE="https://github.com/noctuid/tdrop"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/noctuid/tdrop"
+else
+ SRC_URI="https://github.com/noctuid/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ sys-process/procps
+ x11-apps/xprop
+ x11-apps/xrandr
+ x11-apps/xwininfo
+ x11-misc/xdotool
+"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin tdrop
+ doman tdrop.1
+ dodoc README.org
+}