summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-11 04:25:44 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-11 04:25:44 +0100
commit32362acacb169a0cce7d74ca2a8ad50d3f5a2ed7 (patch)
tree9f0a47c7178638863f020c4309c541a3c9984fc1
parentdev-python/pytest-describe: Bump to 2.2.0 (diff)
downloadgentoo-32362acacb169a0cce7d74ca2a8ad50d3f5a2ed7.tar.gz
gentoo-32362acacb169a0cce7d74ca2a8ad50d3f5a2ed7.tar.bz2
gentoo-32362acacb169a0cce7d74ca2a8ad50d3f5a2ed7.zip
dev-python/pip-run: Bump to 12.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pip-run/Manifest1
-rw-r--r--dev-python/pip-run/pip-run-12.6.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
index 91bc1c0637bd..13aa516f753a 100644
--- a/dev-python/pip-run/Manifest
+++ b/dev-python/pip-run/Manifest
@@ -1 +1,2 @@
DIST pip-run-12.5.0.tar.gz 38695 BLAKE2B a44d35752586bd6d27a2d7e7feebbf904f8552e11becd821e693716b1ef74bfb490a17aacf3b7c19656bbc21fde38e40d29c79a611b2f510c02d199afc8f5cb1 SHA512 b641633c1863745d31637b1ef2a9151c79cc0c647b1bc246dbea5e834ec928b11b29b9cee1952513340bacb1ead610c2b34426b54d76345b57c887b1fe4b68d6
+DIST pip-run-12.6.1.tar.gz 38868 BLAKE2B 852e8207fc5951a4007f761c18dd06b483a0658d3ab3f51e667b5f0a204fe2f2c530ade5d2d36005c2a25d564cb779b5d2911aeaf5e046477631958172414352 SHA512 b4dcdf0d96061b7049bd8ad25e20f36fe305fe04148937cab3be91ab8fc95849b07b14d2948eb0d5172d36f5ef561b80cff07b1203c62f117c52eb5d265e9356
diff --git a/dev-python/pip-run/pip-run-12.6.1.ebuild b/dev-python/pip-run/pip-run-12.6.1.ebuild
new file mode 100644
index 000000000000..18908d5d7407
--- /dev/null
+++ b/dev-python/pip-run/pip-run-12.6.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Install packages and run Python with them"
+HOMEPAGE="
+ https://github.com/jaraco/pip-run/
+ https://pypi.org/project/pip-run/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-env[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.7[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/path[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/flit-core[${PYTHON_USEDEP}]
+ dev-python/jaraco-path[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-test-5.3[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -m "not network"
+}