summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-02-03 08:37:49 +0100
committerMichał Górny <mgorny@gentoo.org>2019-02-03 08:52:05 +0100
commit34ca74d72c24c209f8925e764e733747a912091c (patch)
treec9155c6c25d86b10a2359d611ed8295df4260c53
parentxfce-extra/xfce4-alsa-plugin: Bump to 0.2.0 (diff)
downloadgentoo-34ca74d7.tar.gz
gentoo-34ca74d7.tar.bz2
gentoo-34ca74d7.zip
app-admin/systemrescuecd-x86: Bump to 6.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/systemrescuecd-x86/Manifest1
-rw-r--r--app-admin/systemrescuecd-x86/systemrescuecd-x86-6.0.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-admin/systemrescuecd-x86/Manifest b/app-admin/systemrescuecd-x86/Manifest
index 98da0a99fc98..1d14fe9043f5 100644
--- a/app-admin/systemrescuecd-x86/Manifest
+++ b/app-admin/systemrescuecd-x86/Manifest
@@ -1,3 +1,4 @@
+DIST systemrescuecd-6.0.0.iso 931135488 BLAKE2B 82879883780ff11a35f2fe635a5ee1a268de590bac79326ac2c49c960cd18755b3c10548d65eb5fb7ce5749c00f5040bb10c5ad5b196e48033fb70e3ff466026 SHA512 9bd8c06338357882fd8e3f17ddfb918e1f69e25fff6460957f9c50d496ccc3d4501e39b4596e3f387e4f7a481c9b33d18ba18fb49d74f6d916a7c5997b24c03a
DIST systemrescuecd-x86-5.1.2.iso 523479040 BLAKE2B abf6f1e3e05e382b48dcfd4ecde9f70896462418cf36057e3a42dc2366e0b56133deeb6f00363d15d94238c22fb8ac5c88b57ca6c213c9dcc299fa04def5e2cd SHA512 516e60632459dd5408f83035aa265ed4169b13f978a23960a85837c9c8b5bbab70776e22a6e6727184bd9df81cbbeff4a5819d5927ff0ff3a79036bc4c54cfdc
DIST systemrescuecd-x86-5.2.1.iso 570523648 BLAKE2B 9bb6b2ff7b9930f658baddbf60ef89e86171febcfb48eb0a6ce1bfea8fd3348773a9da948370f9f310dd0e992c40aa64a4ef1442f5cd7f408f847d147074cf1f SHA512 6820f079c9e97ac0d383ed9096a120e7e31771e1d41465f4cf7f5db36a7cb83ccfaae5c5e561181c3b3cb169d4cc4a9a6904a707ecde06a6de4f2456d2a658e4
DIST systemrescuecd-x86-5.2.2.iso 572006400 BLAKE2B 2cc95acc529ae8e0525664ffbdfefaf6e4513e8135fa6af120121b0b7930b0203bd17d5d70ccafacfe0064bb8615f45aa22b6e6e3fcee8a005a0315fd9b5cf62 SHA512 7dd1ccd63775e35f6589808416468c4a9314f4a7a5d0cb1f2bc34ffb9eef3a450b0da244dfc9e325d828c39404c0cdcce27cc990eade33762c17a1e32f8db9b5
diff --git a/app-admin/systemrescuecd-x86/systemrescuecd-x86-6.0.0.ebuild b/app-admin/systemrescuecd-x86/systemrescuecd-x86-6.0.0.ebuild
new file mode 100644
index 000000000000..58953e3649e7
--- /dev/null
+++ b/app-admin/systemrescuecd-x86/systemrescuecd-x86-6.0.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=${P/-x86/}
+DESCRIPTION="The .iso image of SystemRescueCD rescue disk, amd64 variant"
+HOMEPAGE="http://www.sysresccd.org/"
+# Large ISO mirroring explicitly approved by infra in bug #588766
+SRC_URI="mirror://sourceforge/systemrescuecd/sysresccd-${PN#*-}/${PV}/${MY_P}.iso"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+isohybrid"
+
+DEPEND="isohybrid? ( >=sys-boot/syslinux-4 )"
+
+S=${WORKDIR}
+
+pkg_pretend() {
+ ewarn "Please note that starting with version 6.0.0, upstream has switched"
+ ewarn "to Arch Linux as base of their distribution, and running on 32-bit"
+ ewarn "systems is no longer supported."
+}
+
+src_install() {
+ insinto "/usr/share/${PN%-*}"
+ doins "${DISTDIR}/${MY_P}.iso"
+
+ if use isohybrid; then
+ set -- isohybrid -u "${ED%/}/usr/share/${PN%-*}/${MY_P}.iso"
+ echo "${@}"
+ "${@}" || die "${*} failed"
+ fi
+}
+
+pkg_postinst() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # no version newer than ours? we're the newest!
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ ln -f -s -v "${MY_P}.iso" "${f}" || die
+ fi
+}
+
+pkg_postrm() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # if there is no version newer than ours installed
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ # and we are truly and completely uninstalled...
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ # then find an older version to set the symlink to
+ local newest_version=$(best_version "<${CATEGORY}/${PF}")
+
+ if [[ ${newest_version} ]]; then
+ # update the symlink
+ ln -f -s -v "${newest_version%-r*}.iso" "${f}" || die
+ else
+ # last version removed? clean up the symlink
+ rm -v "${f}" || die
+ # and the parent directory
+ rmdir "${f%/*}" || die
+ fi
+ fi
+ fi
+}